<!DOCTYPE html><html id="wmpu-site" lang="en-US" prefix="og: http://ogp.me/ns#"><head><script src="/cdn-cgi/apps/head/jy6C4CJAtgTnN2h9AS6Qu28J3Ck.js"></script><link media="all" href="https://mspoweruser.com/wp-content/cache/autoptimize/css/autoptimize_f7c823c6ef1d967f8a2a2b8754095f0e.css" rel="stylesheet" /><title>GeForce Now loses loads of titles as Microsoft, Warner Bros and more pull out - MSPoweruser</title><meta name="robots" content="index, follow, max-snippet:-1, max-video-preview:-1, max-image-preview:large" /><link rel="canonical" href="https://mspoweruser.com/geforce-now-loses-loads-of-titles-as-microsoft-warner-bros-and-more-pull-out/" /><meta property="og:locale" content="en_US"><meta property="og:type" content="article"><meta property="og:title" content="GeForce Now loses loads of titles as Microsoft, Warner Bros and more pull out - MSPoweruser"><meta property="og:description" content="NVIDIA&#8217;s video game streaming service GeForce Now has lost a huge library of games as major companies pull their titles from the platform. On April 24th, GeForce Now players will be unable to stream titles from Microsoft&#8217;s publishing studio Xbox Game Studios, Warner Bros. Interactive Entertainment, Codemasters, and Klei Entertainment. These departures follow the likes [&hellip;]"><meta property="og:url" content="https://mspoweruser.com/geforce-now-loses-loads-of-titles-as-microsoft-warner-bros-and-more-pull-out/"><meta property="og:site_name" content="MSPoweruser"><meta property="article:publisher" content="https://www.facebook.com/microsoftpoweruser"><meta property="article:section" content="game"><meta property="article:published_time" content="2020-04-21T11:33:50+01:00"><meta property="og:image" content="https://mspoweruser.com/wp-content/uploads/2020/02/nvidia-geforce.jpg"><meta property="og:image:secure_url" content="https://mspoweruser.com/wp-content/uploads/2020/02/nvidia-geforce.jpg"><meta property="og:image:width" content="1280"><meta property="og:image:height" content="680"><meta property="og:image:alt" content="GeForce Now"><meta property="og:image:type" content="image/jpeg"><meta name="twitter:card" content="summary_large_image"><meta name="twitter:title" content="GeForce Now loses loads of titles as Microsoft, Warner Bros and more pull out - MSPoweruser"><meta name="twitter:description" content="NVIDIA&#8217;s video game streaming service GeForce Now has lost a huge library of games as major companies pull their titles from the platform. On April 24th, GeForce Now players will be unable to stream titles from Microsoft&#8217;s publishing studio Xbox Game Studios, Warner Bros. Interactive Entertainment, Codemasters, and Klei Entertainment. These departures follow the likes [&hellip;]"><meta name="twitter:creator" content="@lewis_d_white"><meta name="twitter:image" content="https://mspoweruser.com/wp-content/uploads/2020/02/nvidia-geforce.jpg"> <script type="application/ld+json">{"@context":"https:\/\/schema.org","@graph":[{"@type":"NewsArticle","headline":"GeForce Now loses loads of titles as Microsoft, Warner Bros and more pull out - MSPoweruser","description":"NVIDIA's video game streaming service GeForce Now has lost a huge library of games as major companies pull their titles from the platform.","datePublished":"2020-04-21T11:33:50+01:00","dateModified":"2020-04-21T11:33:50+01:00","publisher":{"@type":"Organization","name":"MSPoweruser","logo":{"@type":"ImageObject","url":"https:\/\/mspoweruser.com\/wp-content\/uploads\/2020\/02\/mspu-logo-transparent-large.png"}},"mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/mspoweruser.com\/geforce-now-loses-loads-of-titles-as-microsoft-warner-bros-and-more-pull-out\/"},"author":{"@type":"Person","name":"Lewis White"},"image":{"@type":"ImageObject","url":"https:\/\/mspoweruser.com\/wp-content\/uploads\/2020\/02\/nvidia-geforce.jpg","width":1280,"height":680}}]}</script> <link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="MSPoweruser &raquo; Feed" href="https://mspoweruser.com/feed/" /><link rel="alternate" type="application/rss+xml" title="MSPoweruser &raquo; Comments Feed" href="https://mspoweruser.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="MSPoweruser &raquo; GeForce Now loses loads of titles as Microsoft, Warner Bros and more pull out Comments Feed" href="https://mspoweruser.com/geforce-now-loses-loads-of-titles-as-microsoft-warner-bros-and-more-pull-out/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/mspoweruser.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);</script> <link crossorigin="anonymous" rel='stylesheet' id='shunno-fonts-css' href='https://fonts.googleapis.com/css?family=Source+Sans+Pro%3A400%2C700%7COpen+Sans%3A400%2C300%2C600%7CRoboto+Condensed%3A400&#038;display=swap&#038;ver=1.1' type='text/css' media='all' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://mspoweruser.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://mspoweruser.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.4" /><link rel='shortlink' href='https://mspoweruser.com/?p=348288' /><link rel="alternate" type="application/json+oembed" href="https://mspoweruser.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmspoweruser.com%2Fgeforce-now-loses-loads-of-titles-as-microsoft-warner-bros-and-more-pull-out%2F" /><link rel="alternate" type="text/xml+oembed" href="https://mspoweruser.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmspoweruser.com%2Fgeforce-now-loses-loads-of-titles-as-microsoft-warner-bros-and-more-pull-out%2F&#038;format=xml" /><link rel="amphtml" href="https://mspoweruser.com/geforce-now-loses-loads-of-titles-as-microsoft-warner-bros-and-more-pull-out/amp/"><script type="text/javascript">//-->//><!--
function readCookie(e){for(var t=e+"=",n=document.cookie.split(";"),o=0;o<n.length;o++){for(var m=n[o];" "==m.charAt(0);)m=m.substring(1,m.length);if(0==m.indexOf(t))return m.substring(t.length,m.length)}return null}if("dark"===readCookie("shunno_site_theme")){var element=document.getElementById("wmpu-site");element.classList.add("dark"),document.write("<meta name='theme-color' content='#2B2B2B'>")}else document.write("<meta name='theme-color' content='#0592ff'>");if("shunnorecom"===readCookie("shunno_recom")){var element=document.getElementById("wmpu-site");element.classList.add("hide-recommended-articles")}if("auto"===readCookie("shunno_auto")){var element=document.getElementById("wmpu-site");element.classList.add("shunno-not-auto")}
//--><!</script> <meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1, user-scalable=no"><link rel="profile" href="http://gmpg.org/xfn/11"><link rel="pingback" href="https://mspoweruser.com/xmlrpc.php"><link rel="apple-touch-icon" sizes="57x57" href="/wp-content/themes/shunno/inc/assets/logos/android-chrome-48x48-min.png"><link rel="apple-touch-icon" sizes="60x60" href="/wp-content/themes/shunno/inc/assets/logos/apple-touch-icon-60x60.png"><link rel="apple-touch-icon" sizes="72x72" href="/wp-content/themes/shunno/inc/assets/logos/apple-touch-icon-72x72.png"><link rel="apple-touch-icon" sizes="76x76" href="/wp-content/themes/shunno/inc/assets/logos/apple-touch-icon-76x76.png"><link rel="apple-touch-icon" sizes="114x114" href="/wp-content/themes/shunno/inc/assets/logos/apple-touch-icon-114x114.png"><link rel="apple-touch-icon" sizes="120x120" href="/wp-content/themes/shunno/inc/assets/logos/apple-touch-icon-120x120.png"><link rel="apple-touch-icon" sizes="144x144" href="/wp-content/themes/shunno/inc/assets/logos/apple-touch-icon-144x144.png"><link rel="apple-touch-icon" sizes="152x152" href="/wp-content/themes/shunno/inc/assets/logos/apple-touch-icon-152x152.png"><link rel="apple-touch-icon" sizes="180x180" href="/wp-content/themes/shunno/inc/assets/logos/apple-touch-icon-180x180.png"><link rel="icon" type="image/png" href="/wp-content/themes/shunno/inc/assets/logos/android-chrome-192x192.png" sizes="192x192"><link rel="shortcut icon" href="/wp-content/themes/shunno/inc/assets/logos/favicon.ico?v=6"><meta name="application-name" content="MSPoweruser" /><meta name="msapplication-TileColor" content="#0592ff" /><meta name="msapplication-tooltip" content="MSPoweruser" /><meta name="msapplication-square70x70logo" content="/wp-content/themes/shunno/inc/assets/logos/wptiles/tiny.png" /><meta name="msapplication-square150x150logo" content="/wp-content/themes/shunno/inc/assets/logos/wptiles/square.png" /><meta name="msapplication-wide310x150logo" content="/wp-content/themes/shunno/inc/assets/logos/wptiles/wide.png" /><meta name="msapplication-square310x310logo" content="/wp-content/themes/shunno/inc/assets/logos/wptiles/large.png" /> <script charset="UTF-8" src="//cdn.sendpulse.com/9dae6d62c816560a842268bde2cd317d/js/push/6fd087f730cb740325c38e8d1e41066e_1.js" async></script> <meta name="msapplication-notification" content="frequency=1800;polling-uri=https://mspoweruser.com/notifications?id=0;polling-uri2=https://mspoweruser.com/notifications?id=1;polling-uri3=https://mspoweruser.com/notifications?id=2;polling-uri4=https://mspoweruser.com/notifications?id=3;polling-uri5=https://mspoweruser.com/notifications?id=4; cycle=1" /></head><body class="post-template-default single single-post postid-348288 single-format-standard"><div id="shunnoham-page" class="hfeed site"><header role="banner"><nav class="shunno-header shunno-mm navbar navbar-fixed-top navbar-default" role="navigation"><div class="shunno-container container"><div class="shunno-logo navbar-header"> <a href="https://mspoweruser.com" title="MSPoweruser - Microsoft and Technology News"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" xmlns:a="http://ns.adobe.com/AdobeSVGViewerExtensions/3.0/" x="0px" y="0px" class="mspu-logo" viewBox="0 0 108.8 129.3" enable-background="new 0 0 108.8 129.3" xml:space="preserve"> <defs> </defs> <path fill="#FFFFFF" d="M50.8,57.6l-7.2,51.2H0V57.6H50.8z M58.9,0H0v51.2h51.6L58.9,0z M47,129.3l20.5-20.5h41.3V57.6H57.2 L47,129.3z M65.2,0L58,51.2h50.8V0H65.2z" /> </svg><span class="name">MSPU</span></a><div class="shunno-nav-menu-button" data-toggle="collapse" data-target="#shunno-ham-mobile" aria-expanded="false"><div class="hamburger-menu"></div></div></div><div id="shunno-ham-mobile" class="shunno-mobile-ham collapse"><ul class="nav shunno-main-nav navbar-nav"><li><a href="https://mspoweruser.com/gaming">Gaming</a></li><li><a href="https://mspoweruser.com/windows-10">Windows 10</a></li><li><a href="https://mspoweruser.com/smartphones">Smartphones</a></li><li><a href="https://mspoweruser.com/surface">Surface</a></li><li><a href="https://mspoweruser.com/Enterprise">Enterprise</a></li><li><a href="https://mspoweruser.com/tips">Tip us</a></li><li><a href="https://mspoweruser.com/settings">Settings</a></li><form role="search" autocomplete="off" method="get" id="search-mobile" action="https://mspoweruser.com/"><div> <label for="name">Text Input:</label> <input type="text" name="s" id="s" value="" tabindex="1" placeholder="Search something....will you?" /> <input type="submit" value="Submit" /></div></form></ul></div><div id="shunno-ham" class="collapse navbar-default shunnocanvas navbar-collapse"><ul class="nav shunno-main-nav navbar-nav"><li class="dropdown shunno-drop"> <a id="megamenu-items-loader-gaming" title="Read the latest articles related to Windows 10 and Xbox games" class="mspu-item dropdown-toggle disabled" href="https://mspoweruser.com/gaming" data-toggle="dropdown">Gaming</a></li><li class="dropdown shunno-drop shunno-mm-fw"> <a id="megamenu-items-loader-windows" title="Read the latest articles related to Windows 10" class="mspu-item dropdown-toggle disabled" href="https://mspoweruser.com/windows-10" data-toggle="dropdown">Windows 10 <span class="caret"></span></a><ul class="dropdown-menu shunno-mm"><li><div class="loader loader-windows"></div><div id="shunno-megamenu-windows"></div></li></ul></li><li class="dropdown shunno-drop shunno-mm-fw"> <a id="megamenu-items-loader-wp" title="Read the latest articles related to Android, iPhones, and Windows Phones" class="mspu-item dropdown-toggle disabled" href="https://mspoweruser.com/smartphones" data-toggle="dropdown">Smartphones <span class="caret"></span></a><ul class="dropdown-menu shunno-mm"><li><div class="loader loader-wp"></div><div id="shunno-megamenu-wp"></div></li></ul></li><li class="shunno-tablet-hide"> <a class="mspu-item" href="https://mspoweruser.com/reviews" title="Get all the latest in-depth game, hardware, and software reviews!">Reviews</a></li></ul><ul class="nav navbar-nav navbar-right shunno-sec-nav"><li class="shunno-fbr shunno-settings"><a href="/settings" title="Customize theme, change settings and more!">Settings</a></li><li class="shunno-fbr shunno-tipus"><a href="/tips" title="Got a news? Make sure to tip us!">Tip us</a></li><li class="shunno-fbr shunno-forum"><a href="http://discuss.mspoweruser.com" title="Join the discussion in the MSPU Forums!">Forum</a></li></ul><ul class="nav navbar-nav navbar-rzr-search"><li class="shunno-search"><form role="search" autocomplete="off" method="get" id="search" action="https://mspoweruser.com/"><div> <label for="name">Text Input:</label> <input type="text" name="s" id="s" value="" tabindex="1" placeholder="Search something....will you?" /> <input type="submit" value="Submit" /></div></form></li></ul></div></div></nav></header><div class="shunnopagenavoverlay"></div><header class="shunno-full-header" style="background-image: url('https://mspoweruser.com/wp-content/uploads/2020/02/nvidia-geforce.jpg');"><div class="shunno-full-meta-box"><div class="shunno-meta-full"><h1 class="entry-title">GeForce Now loses loads of titles as Microsoft, Warner Bros and more pull out</h1><div class="entry-meta"><div class="shunno-post-rate-meta"><div class="shunnopostmetainfo"><p class="pppp">by <a title="View the author's profile" href="https://mspoweruser.com/author/lewis-white/">Lewis White</a></p> &nbsp;<p><a class="twitter-link-single" target="_blank" title="View the author's Twitter profile" href="https://twitter.com/intent/user?screen_name=lewis_d_white"><i class="shunno shunno-twitter"></i>@lewis_d_white</a></p><div class='shunno-post-time'><i class="shunno shunno-clock"></i><time class='timeago'>Apr 21, 2020 at 10:33 GMT</time><time class='timeagohover'>2 hours ago</time></div></div></div></div></div></div></header><div id="primary" class="content-area container"><main id="main" class="site-main shunno-single-article" role="main"><div class="shunno-single-article-internal entry-full-width"><div id="post-348288" class="shunno-article"><div class="shunno-single-main"><div class="shunno-728-header-ad"><script type="text/javascript">var width=window.innerWidth||document.documentElement.clientWidth||document.body.clientWidth;google_ad_client="ca-pub-6210711459792056",width>800?(google_ad_slot="7166200401",google_ad_width=728,google_ad_height=90):800>=width&&width>400?(google_ad_slot="8651626403",google_ad_width=300,google_ad_height=250):(google_ad_slot="8651626403",google_ad_width=300,google_ad_height=250);</script><script type="text/javascript" src="https://pagead2.googlesyndication.com/pagead/show_ads.js"></script></div><div class="entry-content col-md-8 shunno-fw-alternate"><article class="singa"><p><strong>NVIDIA&#8217;s video game streaming service GeForce Now has lost a huge library of games as major companies pull their titles from the platform.</strong></p><p>On April 24th, GeForce Now players will be unable to stream titles from Microsoft&#8217;s publishing studio Xbox Game Studios, Warner Bros. Interactive Entertainment, Codemasters, and Klei Entertainment. These departures follow the likes of <a href="https://mspoweruser.com/nvidia-activision-blizzard-geforce-now-misunderstanding/">Activision-Blizzard and more</a>.</p><p>This is a huge blow for the streaming platform. With major companies removing dozens of AAA games from the service, players will have to instead opt in to a host of different competing platforms to play everything. It&#8217;s just like video streaming all over again.</p><p>&#8220;Games from Warner Bros. Interactive Entertainment, XBOX Game Studios, Codemasters and Klei Entertainment will be removed from the service on Friday, April 24,&#8221; Nvidia announced on their <a href="https://blogs.nvidia.com/blog/2020/04/20/geforce-now-dev-support/" target="_blank" rel="noopener">official blog</a>. &#8220;We hope they’ll return in the future.&#8221;</p><p>Microsoft&#8217;s decision to depart from NVIDIA&#8217;s livestreaming service at least makes sense. With their own <a href="https://mspoweruser.com/project-xcloud-is-expanding-into-11-new-countries/">Project xCloud streaming service still in the works</a>, the studio will want to keep their games tied to their platform. However, with NVIDIA&#8217;s GeForce Now requiring players to purchase their streamed games through official platforms &#8211; such as Steam – they&#8217;re simply losing money from customers that can afford games but not the hardware to run them.</p><div class="video-container"><iframe title="NVIDIA GeForce NOW CES - PC Beta Now Available" width="1140" height="641" src="https://www.youtube.com/embed/zceUpFI16UE?feature=oembed" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div><p>While the streaming service has taken a considerable loss, there is hope on the horizon. NVIDIA has said that &#8220;Ubisoft, Epic, Bungie and Bandai Namco are among the hundreds that have committed to streaming their games on GeForce NOW&#8221; with Ubisoft claiming to fully support the service with the introduction of the complete Assassin’s Creed and Far Cry series.</p></article><footer class="entry-footer"><div class="shunno-728-header-ad"><script type="text/javascript">var width=window.innerWidth||document.documentElement.clientWidth||document.body.clientWidth;google_ad_client="ca-pub-6210711459792056",width>800?(google_ad_slot="7166200401",google_ad_width=728,google_ad_height=90):800>=width&&width>400?(google_ad_slot="8651626403",google_ad_width=300,google_ad_height=250):(google_ad_slot="8651626403",google_ad_width=300,google_ad_height=250);</script><script type="text/javascript" src="https://pagead2.googlesyndication.com/pagead/show_ads.js"></script></div><div class="shunno-share-block"><ul><li> <a class="shunno-share-twitter" title="Tweet on Twitter" href="https://twitter.com/intent/tweet?text=GeForce Now loses loads of titles as Microsoft, Warner Bros and more pull out - https://mspoweruser.com/geforce-now-loses-loads-of-titles-as-microsoft-warner-bros-and-more-pull-out/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"> <i class="shunno shunno-twitter"></i> <span>Tweet</span> </a></li><li> <a class="shunno-share-facebook" title="Share on Facebook" href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fmspoweruser.com%2Fgeforce-now-loses-loads-of-titles-as-microsoft-warner-bros-and-more-pull-out%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"> <i class="shunno shunno-facebook"></i> <span>Share</span> </a></li><li> <a class="shunno-share-skype" title="Share on Skype" href="https://web.skype.com/share?url=https%3A%2F%2Fmspoweruser.com%2Fgeforce-now-loses-loads-of-titles-as-microsoft-warner-bros-and-more-pull-out%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=417,height=655,toolbar=0'); return false;"> <i class="shunno shunno-skype"></i> </a></li><li> <a class="shunno-share-gplus" title="Share on Google+" href="http://plus.google.com/share?url=https%3A%2F%2Fmspoweruser.com%2Fgeforce-now-loses-loads-of-titles-as-microsoft-warner-bros-and-more-pull-out%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"> <i class="shunno shunno-google"></i> </a></li><li> <a class="shunno-share-pocket" title="Save to read later on Pocket" href="https://getpocket.com/save?url=https%3A%2F%2Fmspoweruser.com%2Fgeforce-now-loses-loads-of-titles-as-microsoft-warner-bros-and-more-pull-out%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"> <i class="shunno shunno-pocket"></i> </a></li><li> <a class="shunno-share-reddit" title="Submit to Reddit" href="http://reddit.com/submit?url=https%3A%2F%2Fmspoweruser.com%2Fgeforce-now-loses-loads-of-titles-as-microsoft-warner-bros-and-more-pull-out%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=950,height=450,toolbar=0'); return false;"> <i class="shunno shunno-reddit"></i> </a></li></ul></div><div class="shunno-recommended-articles-full"><div class="shunno-recommended-articles"><div class="source-related-article-header">Read these next<i class="shunno-recommended-article-control shunno shunno-cancel"></i></div><div class="shunno-featured-article-big"><article title="Microsoft should take a cue from this Windows 20 concept video" class="shunno-feat-article"> <a href="https://mspoweruser.com/windows-20-concept/"> <img width="800" height="553" src="https://mspoweruser.com/wp-content/uploads/2020/04/Windows-20-concept-800x553.jpg" class="attachment-shunno-feat-thumb size-shunno-feat-thumb wp-post-image" alt="Microsoft should take a cue from this Windows 20 concept video 1" title="Microsoft should take a cue from this Windows 20 concept video 1"><div class="shunno-featured-article-meta"> <span class="featured-tag">Trending</span><h2>Microsoft should take a cue from this Windows 20 concept video</h2> <span>by Rahul <i class="shunno shunno-comment"></i></span><span class="disqus-comment-count" data-disqus-identifier="348166 https://mspoweruser.com/?p=348166">0</span></div><div class="overlay"></div> </a></article><article title="Deal Alert: Dell XPS 13 9360 13.3&#8243; is now selling at an all-time low price at Amazon" class="shunno-feat-article"> <a href="https://mspoweruser.com/dell-xps-13-9360-discounted-amazon/"> <img width="800" height="522" src="https://mspoweruser.com/wp-content/uploads/2015/10/Dell-XPS-13-800x522.jpg" class="attachment-shunno-feat-thumb size-shunno-feat-thumb wp-post-image" alt="Deal Alert: Dell XPS 13 9360 13.3&quot; is now selling at an all-time low price at Amazon 2" title="Deal Alert: Dell XPS 13 9360 13.3&quot; is now selling at an all-time low price at Amazon 2"><div class="shunno-featured-article-meta"> <span class="featured-tag">Trending</span><h2>Deal Alert: Dell XPS 13 9360 13.3&#8243; is now selling at an all-time low price at Amazon</h2> <span>by Rahul <i class="shunno shunno-comment"></i></span><span class="disqus-comment-count" data-disqus-identifier="348155 https://mspoweruser.com/?p=348155">0</span></div><div class="overlay"></div> </a></article></div></div></div></footer><div class="shunno-728-header-ad"><script type="text/javascript">var width=window.innerWidth||document.documentElement.clientWidth||document.body.clientWidth;google_ad_client="ca-pub-6210711459792056",width>800?(google_ad_slot="7166200401",google_ad_width=728,google_ad_height=90):800>=width&&width>400?(google_ad_slot="8651626403",google_ad_width=300,google_ad_height=250):(google_ad_slot="8651626403",google_ad_width=300,google_ad_height=250);</script><script type="text/javascript" src="https://pagead2.googlesyndication.com/pagead/show_ads.js"></script></div><div class="shunno-single-comments" id="shunno-comments"><div class="shunno-block-title">Comments<span><a href="http://mspoweruser.com/guidelines/" title="Community guidelines"><i class="shunno-guidelines-reveal shunno-attention shunno"></i></a></span></div><div id="disqus_thread"></div></div></div><div id="secondary" class="col-md-4 widget-area" role="complementary"><aside id="shunno_widget_sidebar_advert-3" class="widget shunno_widget_sidebar_advert"><div class="shunno-block-title">Advertisement<a target="_blank" title="Is this advertisment misbehaving or playing sound automatically? Make sure to report this to us and we will disable it asap!" href="https://mspoweruser.com/report-ads"><i class="shunno-report-ad shunno-attention shunno"></i></a></div><div class="shunno-sidebar-advert"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px" data-ad-client="ca-pub-6210711459792056" data-ad-slot="9303911608"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></aside><aside id="shunno_posts_sidebar-4" class="widget widget_shunno_posts_sidebar"><div class="shunno-sidebar-articles"><div class="shunno-block-title shunno-widget-aritlces-title">Windows 10</div><article class="shunno-sidebar-widget-block-big"> <a href="https://mspoweruser.com/windows-20-concept/" title="Microsoft should take a cue from this Windows 20 concept video" class="shunno-widget-overlay"><div class="shunno-side-thumb"><img width="395" height="260" src="https://mspoweruser.com/wp-content/uploads/2020/04/Windows-20-concept-395x260.jpg" class="attachment-shunno-loop-article-thumb size-shunno-loop-article-thumb wp-post-image" alt="Microsoft should take a cue from this Windows 20 concept video 3" srcset="https://mspoweruser.com/wp-content/uploads/2020/04/Windows-20-concept-395x260.jpg 395w, https://mspoweruser.com/wp-content/uploads/2020/04/Windows-20-concept-120x80.jpg 120w, https://mspoweruser.com/wp-content/uploads/2020/04/Windows-20-concept-105x70.jpg 105w" sizes="(max-width: 395px) 100vw, 395px" title="Microsoft should take a cue from this Windows 20 concept video 3"></div><h2>Microsoft should take a cue from this Windows 20 concept video</h2> </a><p>by&nbsp;Rahul&nbsp;on&nbsp;April 20, 2020</p></article><article class="shunno-sidebar-widget-block-small"> <a href="https://mspoweruser.com/windows-10-kb4549951-bsod-bluetooth-bug/" title="Windows 10 KB4549951 update is causing BSOD, Bluetooth and WiFi issues, random system crashes"><div class="shunno-side-thumb"><img width="105" height="70" src="https://mspoweruser.com/wp-content/uploads/2019/11/Windows-10-November-2019-Update-105x70.jpg" class="attachment-shunno-siiiii size-shunno-siiiii wp-post-image" alt="Windows 10 KB4549951 update is causing BSOD, Bluetooth and WiFi issues, random system crashes 4" srcset="https://mspoweruser.com/wp-content/uploads/2019/11/Windows-10-November-2019-Update-105x70.jpg 105w, https://mspoweruser.com/wp-content/uploads/2019/11/Windows-10-November-2019-Update-395x260.jpg 395w, https://mspoweruser.com/wp-content/uploads/2019/11/Windows-10-November-2019-Update-120x80.jpg 120w" sizes="(max-width: 105px) 100vw, 105px" title="Windows 10 KB4549951 update is causing BSOD, Bluetooth and WiFi issues, random system crashes 4"></div><h3>Windows 10 KB4549951 update is causing BSOD, Bluetooth and WiFi issues, random s...</h3></a><p class='shunnowidgetsmallauthor'>by&nbsp;Rahul</p></article><article class="shunno-sidebar-widget-block-small"> <a href="https://mspoweruser.com/download-windows-notepad-microsoft-store/" title="Windows Notepad now available as an app from Microsoft Store"><div class="shunno-side-thumb"><img width="105" height="70" src="https://mspoweruser.com/wp-content/uploads/2020/04/Windows-Notepad-105x70.jpg" class="attachment-shunno-siiiii size-shunno-siiiii wp-post-image" alt="Windows Notepad now available as an app from Microsoft Store 5" srcset="https://mspoweruser.com/wp-content/uploads/2020/04/Windows-Notepad-105x70.jpg 105w, https://mspoweruser.com/wp-content/uploads/2020/04/Windows-Notepad-395x260.jpg 395w, https://mspoweruser.com/wp-content/uploads/2020/04/Windows-Notepad-120x80.jpg 120w" sizes="(max-width: 105px) 100vw, 105px" title="Windows Notepad now available as an app from Microsoft Store 5"></div><h3>Windows Notepad now available as an app from Microsoft Store</h3></a><p class='shunnowidgetsmallauthor'>by&nbsp;Pradeep</p></article><article class="shunno-sidebar-widget-block-small"> <a href="https://mspoweruser.com/microsoft-updated-windows-10-insider-build-19608-reliability-fix/" title="Microsoft updated Windows 10 Insider Build 19608 with reliability fix"><div class="shunno-side-thumb"><img width="105" height="70" src="https://mspoweruser.com/wp-content/uploads/2020/04/Windows-10-Settings-105x70.png" class="attachment-shunno-siiiii size-shunno-siiiii wp-post-image" alt="Microsoft updated Windows 10 Insider Build 19608 with reliability fix 6" srcset="https://mspoweruser.com/wp-content/uploads/2020/04/Windows-10-Settings-105x70.png 105w, https://mspoweruser.com/wp-content/uploads/2020/04/Windows-10-Settings-395x260.png 395w, https://mspoweruser.com/wp-content/uploads/2020/04/Windows-10-Settings-120x80.png 120w" sizes="(max-width: 105px) 100vw, 105px" title="Microsoft updated Windows 10 Insider Build 19608 with reliability fix 6"></div><h3>Microsoft updated Windows 10 Insider Build 19608 with reliability fix</h3></a><p class='shunnowidgetsmallauthor'>by&nbsp;Surur</p></article><article class="shunno-sidebar-widget-block-small"> <a href="https://mspoweruser.com/the-windows-10-app-you-never-use-has-a-new-icon/" title="The Windows 10 app you never use has a new icon"><div class="shunno-side-thumb"><img width="105" height="70" src="https://mspoweruser.com/wp-content/uploads/2020/04/maps1-105x70.png" class="attachment-shunno-siiiii size-shunno-siiiii wp-post-image" alt="The Windows 10 app you never use has a new icon 7" srcset="https://mspoweruser.com/wp-content/uploads/2020/04/maps1-105x70.png 105w, https://mspoweruser.com/wp-content/uploads/2020/04/maps1-395x260.png 395w, https://mspoweruser.com/wp-content/uploads/2020/04/maps1-120x80.png 120w" sizes="(max-width: 105px) 100vw, 105px" title="The Windows 10 app you never use has a new icon 7"></div><h3>The Windows 10 app you never use has a new icon</h3></a><p class='shunnowidgetsmallauthor'>by&nbsp;Surur</p></article></div></aside><aside id="shunno_widget_sidebar_sovrnadsmall-2" class="widget shunno_widget_sidebar_sovrnadsmall"><div class="shunno-block-title">Advertisement<a target="_blank" title="Is this advertisment misbehaving or playing sound automatically? Make sure to report this to us and we will disable it asap!" href="https://mspoweruser.com/report-ads"><i class="shunno-report-ad shunno-attention shunno"></i></a></div><div class="shunno-sidebar-advert"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6210711459792056" data-ad-slot="8185229604"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></aside><aside id="shunno_posts_sidebar_deals-2" class="widget widget_shunno_posts_sidebar_deals"><div class="shunno-sidebar-articles shunno-widget-deals"><div class="shunno-block-title shunno-widget-aritlces-title">Deals</div><article class="shunno-sidebar-widget-block-big"> <a href="https://mspoweruser.com/microsoft-surface-pro-x-bundle-deal/" title="Deal Alert: Get $290 discount on Surface Pro X + Signature Keyboard with Slim Pen Bundle" class="shunno-widget-overlay"><div class="shunno-side-thumb"><img width="395" height="260" src="https://mspoweruser.com/wp-content/uploads/2019/10/Surface-Pro-X-pre-order-395x260.jpg" class="attachment-shunno-loop-article-thumb size-shunno-loop-article-thumb wp-post-image" alt="Deal Alert: Get $290 discount on Surface Pro X + Signature Keyboard with Slim Pen Bundle 8" srcset="https://mspoweruser.com/wp-content/uploads/2019/10/Surface-Pro-X-pre-order-395x260.jpg 395w, https://mspoweruser.com/wp-content/uploads/2019/10/Surface-Pro-X-pre-order-150x99.jpg 150w, https://mspoweruser.com/wp-content/uploads/2019/10/Surface-Pro-X-pre-order-120x80.jpg 120w, https://mspoweruser.com/wp-content/uploads/2019/10/Surface-Pro-X-pre-order-105x70.jpg 105w" sizes="(max-width: 395px) 100vw, 395px" title="Deal Alert: Get $290 discount on Surface Pro X + Signature Keyboard with Slim Pen Bundle 8"></div><h2>Deal Alert: Get $290 discount on Surface Pro X + Signature Keyboard with Slim Pen Bundle</h2> </a><p class="article-excerpt">You can now get a steep $290 discount on Surface Pro X bundle, which includes the Surface Pro X device, Signature Keyboard and the Slim Pen. Amazon is currently offering the Black Surface Pr...</p></article><article class="shunno-sidebar-widget-block-small"> <a href="https://mspoweruser.com/deal-surface-pro-7-discount/" title="Deal Alert: Save up to $300 on Microsoft Surface Pro 7"><div class="shunno-side-thumb"><img width="105" height="70" src="https://mspoweruser.com/wp-content/uploads/2019/10/Surface-Pro-7-4-105x70.jpg" class="attachment-shunno-siiiii size-shunno-siiiii wp-post-image" alt="surface pro 7 deals" srcset="https://mspoweruser.com/wp-content/uploads/2019/10/Surface-Pro-7-4-105x70.jpg 105w, https://mspoweruser.com/wp-content/uploads/2019/10/Surface-Pro-7-4-395x260.jpg 395w, https://mspoweruser.com/wp-content/uploads/2019/10/Surface-Pro-7-4-120x80.jpg 120w" sizes="(max-width: 105px) 100vw, 105px" title="Deal Alert: Save up to $300 on Microsoft Surface Pro 7 10"></div><h3>Deal Alert: Save up to $300 on Microsoft Surface Pro 7</h3></a><p class="article-excerpt">You can now get a huge $300 discount on the purchase of the Surface Pro 7 (256GB). The Surface Pro 7 with i5 processor, 8GB RAM, and 256GB storage is now available at a price point of $899, ...</p></article><article class="shunno-sidebar-widget-block-small"> <a href="https://mspoweruser.com/surface-book-2-is-559-cheaper-today/" title="Deal Alert: Microsoft Surface Book 2 is $559 cheaper today"><div class="shunno-side-thumb"><img width="105" height="70" src="https://mspoweruser.com/wp-content/uploads/2017/10/surface-book-2-5-105x70.jpg" class="attachment-shunno-siiiii size-shunno-siiiii wp-post-image" alt="Deal Alert: Microsoft Surface Book 2 is $559 cheaper today 10" srcset="https://mspoweruser.com/wp-content/uploads/2017/10/surface-book-2-5-105x70.jpg 105w, https://mspoweruser.com/wp-content/uploads/2017/10/surface-book-2-5-395x260.jpg 395w, https://mspoweruser.com/wp-content/uploads/2017/10/surface-book-2-5-120x80.jpg 120w" sizes="(max-width: 105px) 100vw, 105px" title="Deal Alert: Microsoft Surface Book 2 is $559 cheaper today 12"></div><h3>Deal Alert: Microsoft Surface Book 2 is $559 cheaper today</h3></a><p class="article-excerpt">You can now get a Microsoft Surface Book 2 device with Intel Core i7, 13.5-inch display, 16GB RAM and 512GB storage for just $2,071 —that’s $427.63 cheaper than the usual price($2,499). ...</p></article><article class="shunno-sidebar-widget-block-small"> <a href="https://mspoweruser.com/echo-dot-3rd-gen-discounted-amazon/" title="Deal Alert: Echo Dot (3rd Gen) price is back to its record low"><div class="shunno-side-thumb"><img width="105" height="70" src="https://mspoweruser.com/wp-content/uploads/2019/12/third-gen-echo-dot-105x70.jpg" class="attachment-shunno-siiiii size-shunno-siiiii wp-post-image" alt="Deal Alert: Echo Dot (3rd Gen) price is back to its record low 11" srcset="https://mspoweruser.com/wp-content/uploads/2019/12/third-gen-echo-dot-105x70.jpg 105w, https://mspoweruser.com/wp-content/uploads/2019/12/third-gen-echo-dot-395x260.jpg 395w, https://mspoweruser.com/wp-content/uploads/2019/12/third-gen-echo-dot-120x80.jpg 120w" sizes="(max-width: 105px) 100vw, 105px" title="Deal Alert: Echo Dot (3rd Gen) price is back to its record low 13"></div><h3>Deal Alert: Echo Dot (3rd Gen) price is back to its record low</h3></a><p class="article-excerpt">If asking digital assistants to play music, answer questions, read stories, and tell jokes is your thing, then Amazon Echo Dot is definitely a great product and in many aspects, it’s even ...</p></article><article class="shunno-sidebar-widget-block-small"> <a href="https://mspoweruser.com/microsoft-surface-pro-x-deal-alert/" title="Deal Alert: Get $320 discount on Surface Pro X + Signature Keyboard with Slim Pen Bundle"><div class="shunno-side-thumb"><img width="105" height="70" src="https://mspoweruser.com/wp-content/uploads/2019/10/Surface-Pro-X-pre-order-105x70.jpg" class="attachment-shunno-siiiii size-shunno-siiiii wp-post-image" alt="Deal Alert: Get $320 discount on Surface Pro X + Signature Keyboard with Slim Pen Bundle 13" srcset="https://mspoweruser.com/wp-content/uploads/2019/10/Surface-Pro-X-pre-order-105x70.jpg 105w, https://mspoweruser.com/wp-content/uploads/2019/10/Surface-Pro-X-pre-order-150x99.jpg 150w, https://mspoweruser.com/wp-content/uploads/2019/10/Surface-Pro-X-pre-order-300x199.jpg 300w, https://mspoweruser.com/wp-content/uploads/2019/10/Surface-Pro-X-pre-order-395x260.jpg 395w, https://mspoweruser.com/wp-content/uploads/2019/10/Surface-Pro-X-pre-order-120x80.jpg 120w, https://mspoweruser.com/wp-content/uploads/2019/10/Surface-Pro-X-pre-order.jpg 1092w" sizes="(max-width: 105px) 100vw, 105px" title="Deal Alert: Get $320 discount on Surface Pro X + Signature Keyboard with Slim Pen Bundle 15"></div><h3>Deal Alert: Get $320 discount on Surface Pro X + Signature Keyboard with Slim Pe...</h3></a><p class="article-excerpt">Microsoft is offering a steep $320 discount for its Surface Pro X bundle, which includes the Signature Keyboard with Slim Pen. Microsoft is currently offering the Black Surface Pro X + Black...</p></article><article class="shunno-sidebar-widget-block-small"> <a href="https://mspoweruser.com/deal-alert-surface-pro-7-300-discount/" title="Deal Alert: Surface Pro 7 is $300 cheaper today"><div class="shunno-side-thumb"><img width="105" height="70" src="https://mspoweruser.com/wp-content/uploads/2019/10/Surface-Pro-7-4-105x70.jpg" class="attachment-shunno-siiiii size-shunno-siiiii wp-post-image" alt="surface pro 7 deals" srcset="https://mspoweruser.com/wp-content/uploads/2019/10/Surface-Pro-7-4-105x70.jpg 105w, https://mspoweruser.com/wp-content/uploads/2019/10/Surface-Pro-7-4-395x260.jpg 395w, https://mspoweruser.com/wp-content/uploads/2019/10/Surface-Pro-7-4-120x80.jpg 120w" sizes="(max-width: 105px) 100vw, 105px" title="Deal Alert: Surface Pro 7 is $300 cheaper today 17"></div><h3>Deal Alert: Surface Pro 7 is $300 cheaper today</h3></a><p class="article-excerpt">Microsoft’s latest Surface Pro, the Surface Pro 7 is not only versatile and light but also comes with full Windows 10 and that means you can do pretty much everything with it. It’s also ...</p></article><article class="shunno-sidebar-widget-block-small"> <a href="https://mspoweruser.com/deal-apple-airpods-with-charging-case/" title="Deal Alert: Apple AirPods with Charging Case now available at a discounted price"><div class="shunno-side-thumb"><img width="105" height="70" src="https://mspoweruser.com/wp-content/uploads/2020/01/Apple-AirPods-105x70.jpg" class="attachment-shunno-siiiii size-shunno-siiiii wp-post-image" alt="Deal Alert: Apple AirPods with Charging Case now available at a discounted price 15" srcset="https://mspoweruser.com/wp-content/uploads/2020/01/Apple-AirPods-105x70.jpg 105w, https://mspoweruser.com/wp-content/uploads/2020/01/Apple-AirPods-395x260.jpg 395w, https://mspoweruser.com/wp-content/uploads/2020/01/Apple-AirPods-120x80.jpg 120w" sizes="(max-width: 105px) 100vw, 105px" title="Deal Alert: Apple AirPods with Charging Case now available at a discounted price 18"></div><h3>Deal Alert: Apple AirPods with Charging Case now available at a discounted price</h3></a><p class="article-excerpt">Apple AirPods with the wireless charging case is now available at $169, down from $199. Apple AirPods with regular charging case is now available at $129, down from $159. The discounted pric...</p></article><article class="shunno-sidebar-widget-block-small"> <a href="https://mspoweruser.com/deal-alert-15-surface-book-2-is-449-cheaper-today/" title="Deal Alert: 15&#8243; Surface Book 2 is $449 cheaper today"><div class="shunno-side-thumb"><img width="105" height="70" src="https://mspoweruser.com/wp-content/uploads/2017/10/surface-book-2-5-105x70.jpg" class="attachment-shunno-siiiii size-shunno-siiiii wp-post-image" alt="Deal Alert: 15&quot; Surface Book 2 is $449 cheaper today 16" srcset="https://mspoweruser.com/wp-content/uploads/2017/10/surface-book-2-5-105x70.jpg 105w, https://mspoweruser.com/wp-content/uploads/2017/10/surface-book-2-5-395x260.jpg 395w, https://mspoweruser.com/wp-content/uploads/2017/10/surface-book-2-5-120x80.jpg 120w" sizes="(max-width: 105px) 100vw, 105px" title="Deal Alert: 15&quot; Surface Book 2 is $449 cheaper today 20"></div><h3>Deal Alert: 15&#8243; Surface Book 2 is $449 cheaper today</h3></a><p class="article-excerpt">You can now get a Microsoft Surface Book 2 device with Intel Core i7, 15-inch display, 16GB RAM and 500GB storage for just $2,449 —that’s $449 cheaper than the usual price($2,899). Find ...</p></article><article class="shunno-sidebar-widget-block-small"> <a href="https://mspoweruser.com/deal-alert-google-pixel-3a/" title="Deal Alert: Google Pixel 3a is now available at a record low price"><div class="shunno-side-thumb"><img width="105" height="70" src="https://mspoweruser.com/wp-content/uploads/2019/11/Google-Pixel-3a-105x70.jpg" class="attachment-shunno-siiiii size-shunno-siiiii wp-post-image" alt="Deal Alert: Google Pixel 3a is now available at a record low price 17" srcset="https://mspoweruser.com/wp-content/uploads/2019/11/Google-Pixel-3a-105x70.jpg 105w, https://mspoweruser.com/wp-content/uploads/2019/11/Google-Pixel-3a-395x260.jpg 395w, https://mspoweruser.com/wp-content/uploads/2019/11/Google-Pixel-3a-120x80.jpg 120w" sizes="(max-width: 105px) 100vw, 105px" title="Deal Alert: Google Pixel 3a is now available at a record low price 21"></div><h3>Deal Alert: Google Pixel 3a is now available at a record low price</h3></a><p class="article-excerpt">If you want to get a real taste of Google’s Android, you’ll have only one choice and that is Google Pixel. The Pixel lineup showcases the best of Android and the best part is you don’t...</p></article><article class="shunno-sidebar-widget-block-small"> <a href="https://mspoweruser.com/deal-alert-surface-headphones-microsoft-store/" title="Deal Alert: Surface Headphones now at all time low price at Microsoft Store"><div class="shunno-side-thumb"><img width="105" height="70" src="https://mspoweruser.com/wp-content/uploads/2018/10/surface-headphones-6_web-105x70.jpg" class="attachment-shunno-siiiii size-shunno-siiiii wp-post-image" alt="Deal Alert: Surface Headphones now at all time low price at Microsoft Store 18" srcset="https://mspoweruser.com/wp-content/uploads/2018/10/surface-headphones-6_web-105x70.jpg 105w, https://mspoweruser.com/wp-content/uploads/2018/10/surface-headphones-6_web-150x100.jpg 150w, https://mspoweruser.com/wp-content/uploads/2018/10/surface-headphones-6_web-300x200.jpg 300w, https://mspoweruser.com/wp-content/uploads/2018/10/surface-headphones-6_web-395x260.jpg 395w, https://mspoweruser.com/wp-content/uploads/2018/10/surface-headphones-6_web-120x80.jpg 120w, https://mspoweruser.com/wp-content/uploads/2018/10/surface-headphones-6_web.jpg 1000w" sizes="(max-width: 105px) 100vw, 105px" title="Deal Alert: Surface Headphones now at all time low price at Microsoft Store 22"></div><h3>Deal Alert: Surface Headphones now at all time low price at Microsoft Store</h3></a><p class="article-excerpt">Surface Headphones are arguably the most exciting noise-canceling headphones that launched last year. It not only offers great sound quality and great noise cancelation but it also features ...</p></article></div></aside><aside id="shunno_widget_sidebar_sovrnad-2" class="widget shunno_widget_sidebar_sovrnad"><div class="shunno-block-title">Advertisement<a target="_blank" title="Is this advertisment misbehaving or playing sound automatically? Make sure to report this to us and we will disable it asap!" href="https://mspoweruser.com/report-ads"><i class="shunno-report-ad shunno-attention shunno"></i></a></div><div class="shunno-sidebar-advert"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px" data-ad-client="ca-pub-6210711459792056" data-ad-slot="6708496403"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></aside><aside id="custom_html-3" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><a href="https://opencritic.com/outlet/704/mspoweruser" target="_blank" rel="noopener noreferrer"><img src="https://mspoweruser.com/wp-content/uploads/2019/05/opencriticlogo2.png" alt="Open Critic" /></a></div></aside></div></div></div></div></main></div></div></div><footer id="colophon" class="site-footer" role="contentinfo"><div class="shunno-footer-main container"><div class="col-md-4 footer-logo"> <a href="http://mspoweruser.com" title="MSPoweruser - All of Microsoft, all of the time!"> <img alt="shunno-footer-logo" src="//mspoweruser.com/wp-content/themes/shunno/inc/assets/footer-logos.png" style="width: 100%;"> </a></div><div class="col-md-8 footer-links"><ul class="site-links"> <a href="http://discuss.mspoweruser.com" target="_blank"><li>Forums</li></a> <a href="http://mspoweruser.com/about"><li>About Us</li></a> <a href="http://mspoweruser.com/contact"><li>Contact Us</li></a> <a href="http://mspoweruser.com/tips"><li>Tip Us</li></a> <a href="http://mspoweruser.com/submit-articles/"><li>Submit Articles</li></a> <a href="http://mspoweruser.com/guidelines"><li>Community Guidelines</li></a> <a href="http://mspoweruser.com/privacy"><li class="site-links-privacy">Privacy Policy</li></a></ul><ul class="social-links"> <a title="Follow the latest conversations on Disqus" href="https://disqus.com/home/forum/mspoweruser/"><li class="social-links-disqus"><i class="shunno shunno-disqus"></i></li></a> <a title="Subscribe to our RSS feed" href="https://mspoweruser.com/feed"><li><i class="shunno shunno-rss"></i></li></a> <a title="Follow us on Google+" href="https://plus.google.com/+mspoweruserhd"><li class="shunnogooglelink"><i class="shunno shunno-google"></i></li></a> <a title="Like us on Facebook" href="https://facebook.com/microsoftpoweruser"><li><i class="shunno shunno-facebook"></i></li></a> <a title="Follow us on Twitter" href="https://twitter.com/mspoweruser"><li><i class="shunno shunno-twitter"></i></li></a></ul></div><div class="footer-copyright"> <span>&copy; 2020 MSPoweruser - All rights reserved</span><span class="footer-queries">Not associated with Microsoft</span></div></div><div class="afs_ads">&nbsp;</div></footer><div id="iossafari-a2h-banner" class="" style="display:none;"> <img class="pwa-logo-icon" src="https://mspoweruser.com/wp-content/uploads/2020/03/mspu-pwa-logo.png" /><div class="pwa-ov-txt"><p> Install MSPoweruser on your iPhone <img class="pwa-a2h-icon" src="https://mspoweruser.com/wp-content/plugins/call-to-action-for-pwa/images/upload.png" /> and then <span class="ath"> Add to Home Screen </span></p></div> <a class="pwaforwp_iossafari_close">&times;</a> <span class="arow"></span></div><script type='text/javascript'>var pwa_cta_assets = {"a2h_sticky_on_desktop_cta":"0","a2h_banner_without_scroll_cta":"0"};</script> <script type='text/javascript'>var wpcf7 = {"apiSettings":{"root":"https:\/\/mspoweruser.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};</script> <script type='text/javascript'>var countVars = {"disqusShortname":"mspoweruser"};</script> <script type='text/javascript'>var embedVars = {"disqusConfig":{"platform":"wordpress"},"disqusIdentifier":"348288 https:\/\/mspoweruser.com\/?p=348288","disqusShortname":"mspoweruser","disqusTitle":"GeForce Now loses loads of titles as Microsoft, Warner Bros and more pull out","disqusUrl":"https:\/\/mspoweruser.com\/geforce-now-loses-loads-of-titles-as-microsoft-warner-bros-and-more-pull-out\/","postId":"348288"};</script> <script type='text/javascript' src='https://stats.wp.com/e-202017.js' async='async' defer='defer'></script> <script type='text/javascript'>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.4.2',blog:'107264148',post:'348288',tz:'1',srv:'mspoweruser.com'} ]);
	_stq.push([ 'clickTrackerInit', '107264148', '348288' ]);</script> <a href="#0" class="shunno-top">Top</a></div> <script defer src="https://mspoweruser.com/wp-content/cache/autoptimize/js/autoptimize_84d220fee24fbcd3ebd43fc7ad59b522.js"></script></body></html>