<!DOCTYPE html><html id="wmpu-site" lang="en-US" prefix="og: https://ogp.me/ns#"><head><script src="/cdn-cgi/apps/head/jy6C4CJAtgTnN2h9AS6Qu28J3Ck.js"></script><link media="all" href="https://mspoweruser.com/wp-content/cache/autoptimize/css/autoptimize_515a6ea6c4019c07708c8c438ed54941.css" rel="stylesheet" /><title>Google cuts Google Play fees to 15% or less for most developers - MSPoweruser</title><meta name="robots" content="index, follow, max-snippet:-1, max-video-preview:-1, max-image-preview:large" /><link rel="canonical" href="https://mspoweruser.com/google-cuts-google-play-fees-to-15-or-less-for-most-developers/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Google cuts Google Play fees to 15% or less for most developers - MSPoweruser" /><meta property="og:description" content="Google has announced that it is making significant cuts to the service fees it charge to Google Play developers. The company noted that 97% of developers had free apps and monetized outside the Play Store, and were not subject to fees in any case. For the 3% of developers who transacted via the Store, Google [&hellip;]" /><meta property="og:url" content="https://mspoweruser.com/google-cuts-google-play-fees-to-15-or-less-for-most-developers/" /><meta property="og:site_name" content="MSPoweruser" /><meta property="article:publisher" content="https://www.facebook.com/microsoftpoweruser" /><meta property="article:author" content="http://www.facebook.com/pages/wmpowerusercom/37708414657" /><meta property="article:tag" content="google play" /><meta property="article:section" content="android" /><meta property="og:image" content="https://mspoweruser.com/wp-content/uploads/2019/04/Google-Play-Store-1200x656.jpg" /><meta property="og:image:secure_url" content="https://mspoweruser.com/wp-content/uploads/2019/04/Google-Play-Store-1200x656.jpg" /><meta property="og:image:width" content="1140" /><meta property="og:image:height" content="623" /><meta property="og:image:alt" content="google" /><meta property="og:image:type" content="image/jpeg" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:title" content="Google cuts Google Play fees to 15% or less for most developers - MSPoweruser" /><meta name="twitter:description" content="Google has announced that it is making significant cuts to the service fees it charge to Google Play developers. The company noted that 97% of developers had free apps and monetized outside the Play Store, and were not subject to fees in any case. For the 3% of developers who transacted via the Store, Google [&hellip;]" /><meta name="twitter:site" content="@mspoweruser" /><meta name="twitter:creator" content="@mspoweruser" /><meta name="twitter:image" content="https://mspoweruser.com/wp-content/uploads/2019/04/Google-Play-Store-1200x656.jpg" /> <script type="application/ld+json" class="rank-math-schema">{"@context":"https://schema.org","@graph":[{"@type":["Website","Organization"],"@id":"https://mspoweruser.com/#organization","name":"MSPoweruser","url":"https://mspoweruser.com","logo":{"@type":"ImageObject","@id":"https://mspoweruser.com/#logo","url":"https://mspoweruser.com/wp-content/uploads/2020/02/mspu-logo-transparent-large.png","caption":"MSPoweruser","inLanguage":"en-US","width":"781","height":"912"},"openingHours":["Monday,Tuesday,Wednesday,Thursday,Friday,Saturday,Sunday 09:00-17:00"]},{"@type":"WebSite","@id":"https://mspoweruser.com/#website","url":"https://mspoweruser.com","name":"MSPoweruser","publisher":{"@id":"https://mspoweruser.com/#organization"},"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://mspoweruser.com/wp-content/uploads/2019/04/Google-Play-Store.jpg","url":"https://mspoweruser.com/wp-content/uploads/2019/04/Google-Play-Store.jpg","width":"2055","height":"1123","inLanguage":"en-US"},{"@type":"Person","@id":"https://mspoweruser.com/author/surur/","name":"Surur","url":"https://mspoweruser.com/author/surur/","image":{"@type":"ImageObject","@id":"https://secure.gravatar.com/avatar/d1de60b58525af57cc6c28f72d305a9d?s=96&amp;d=mm&amp;r=g","url":"https://secure.gravatar.com/avatar/d1de60b58525af57cc6c28f72d305a9d?s=96&amp;d=mm&amp;r=g","caption":"Surur","inLanguage":"en-US"},"sameAs":["http://MSPoweruser.com","http://www.facebook.com/pages/wmpowerusercom/37708414657","https://twitter.com/mspoweruser"],"worksFor":{"@id":"https://mspoweruser.com/#organization"}},{"@type":"WebPage","@id":"https://mspoweruser.com/google-cuts-google-play-fees-to-15-or-less-for-most-developers/#webpage","url":"https://mspoweruser.com/google-cuts-google-play-fees-to-15-or-less-for-most-developers/","name":"Google cuts Google Play fees to 15% or less for most developers - MSPoweruser","datePublished":"2021-10-22T16:25:57+01:00","dateModified":"2021-10-22T16:25:57+01:00","author":{"@id":"https://mspoweruser.com/author/surur/"},"isPartOf":{"@id":"https://mspoweruser.com/#website"},"primaryImageOfPage":{"@id":"https://mspoweruser.com/wp-content/uploads/2019/04/Google-Play-Store.jpg"},"inLanguage":"en-US"},{"@type":"NewsArticle","headline":"Google cuts Google Play fees to 15% or less for most developers - MSPoweruser","keywords":"google","datePublished":"2021-10-22T16:25:57+01:00","dateModified":"2021-10-22T16:25:57+01:00","author":{"@id":"https://mspoweruser.com/author/surur/"},"publisher":{"@id":"https://mspoweruser.com/#organization"},"description":"Google has announced that it is making significant cuts to the service fees it charge to Google Play developers.","name":"Google cuts Google Play fees to 15% or less for most developers - MSPoweruser","@id":"https://mspoweruser.com/google-cuts-google-play-fees-to-15-or-less-for-most-developers/#richSnippet","isPartOf":{"@id":"https://mspoweruser.com/google-cuts-google-play-fees-to-15-or-less-for-most-developers/#webpage"},"image":{"@id":"https://mspoweruser.com/wp-content/uploads/2019/04/Google-Play-Store.jpg"},"inLanguage":"en-US","mainEntityOfPage":{"@id":"https://mspoweruser.com/google-cuts-google-play-fees-to-15-or-less-for-most-developers/#webpage"}}]}</script> <link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel='dns-prefetch' href='//pagead2.googlesyndication.com' /><link rel="alternate" type="application/rss+xml" title="MSPoweruser &raquo; Feed" href="https://mspoweruser.com/feed/" /><link rel="alternate" type="application/rss+xml" title="MSPoweruser &raquo; Comments Feed" href="https://mspoweruser.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="MSPoweruser &raquo; Google cuts Google Play fees to 15% or less for most developers Comments Feed" href="https://mspoweruser.com/google-cuts-google-play-fees-to-15-or-less-for-most-developers/feed/" /><link rel="alternate" type="application/rss+xml" title="MSPoweruser &raquo; Stories Feed" href="https://mspoweruser.com/web-stories/feed/"> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/mspoweruser.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.1"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);</script> <link crossorigin="anonymous" rel='stylesheet' id='shunno-fonts-css' href='https://fonts.googleapis.com/css?family=Source+Sans+Pro%3A400%2C700%7COpen+Sans%3A400%2C300%2C600%7CRoboto+Condensed%3A400&#038;display=swap&#038;ver=1.1' type='text/css' media='all' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://mspoweruser.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://mspoweruser.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.8.1" /><link rel='shortlink' href='https://mspoweruser.com/?p=390749' /><link rel="alternate" type="application/json+oembed" href="https://mspoweruser.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmspoweruser.com%2Fgoogle-cuts-google-play-fees-to-15-or-less-for-most-developers%2F" /><link rel="alternate" type="text/xml+oembed" href="https://mspoweruser.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmspoweruser.com%2Fgoogle-cuts-google-play-fees-to-15-or-less-for-most-developers%2F&#038;format=xml" /><meta name="generator" content="Site Kit by Google 1.37.0" /> <script type="text/javascript">function nxsPostToFav(obj){ obj.preventDefault;
            var k = obj.target.split("-"); var nt = k[0]; var ii = k[1];  var pid = k[2];
            var data = {  action:'nxs_snap_aj', nxsact: 'manPost', nt:nt, id: pid, nid: ii, et_load_builder_modules:1, _wpnonce: '310830e535'};
            jQuery('#nxsFavNoticeCnt').html('<p> Posting... </p>'); jQuery('#nxsFavNotice').modal({ fadeDuration: 50 });
            jQuery.post('https://mspoweruser.com/wp-admin/admin-ajax.php', data, function(response) { if (response=='') response = 'Message Posted';
                jQuery('#nxsFavNoticeCnt').html('<p> ' + response + '</p>' +'<input type="button"  onclick="jQuery.modal.close();" class="bClose" value="Close" />');
            });
        }</script> <link rel="amphtml" href="https://mspoweruser.com/google-cuts-google-play-fees-to-15-or-less-for-most-developers/amp/"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script>(adsbygoogle = window.adsbygoogle || []).push({"google_ad_client":"ca-pub-6210711459792056","enable_page_level_ads":true,"tag_partner":"site_kit"});</script><script type="text/javascript">//-->//><!--
function readCookie(e){for(var t=e+"=",n=document.cookie.split(";"),o=0;o<n.length;o++){for(var m=n[o];" "==m.charAt(0);)m=m.substring(1,m.length);if(0==m.indexOf(t))return m.substring(t.length,m.length)}return null}if("dark"===readCookie("shunno_site_theme")){var element=document.getElementById("wmpu-site");element.classList.add("dark"),document.write("<meta name='theme-color' content='#2B2B2B'>")}else document.write("<meta name='theme-color' content='#0592ff'>");if("shunnorecom"===readCookie("shunno_recom")){var element=document.getElementById("wmpu-site");element.classList.add("hide-recommended-articles")}if("auto"===readCookie("shunno_auto")){var element=document.getElementById("wmpu-site");element.classList.add("shunno-not-auto")}
//--><!</script> <meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1, user-scalable=no"><link rel="profile" href="http://gmpg.org/xfn/11"><link rel="pingback" href="https://mspoweruser.com/xmlrpc.php"><link rel="apple-touch-icon" sizes="57x57" href="/wp-content/themes/shunno/inc/assets/logos/android-chrome-48x48-min.png"><link rel="apple-touch-icon" sizes="60x60" href="/wp-content/themes/shunno/inc/assets/logos/apple-touch-icon-60x60.png"><link rel="apple-touch-icon" sizes="72x72" href="/wp-content/themes/shunno/inc/assets/logos/apple-touch-icon-72x72.png"><link rel="apple-touch-icon" sizes="76x76" href="/wp-content/themes/shunno/inc/assets/logos/apple-touch-icon-76x76.png"><link rel="apple-touch-icon" sizes="114x114" href="/wp-content/themes/shunno/inc/assets/logos/apple-touch-icon-114x114.png"><link rel="apple-touch-icon" sizes="120x120" href="/wp-content/themes/shunno/inc/assets/logos/apple-touch-icon-120x120.png"><link rel="apple-touch-icon" sizes="144x144" href="/wp-content/themes/shunno/inc/assets/logos/apple-touch-icon-144x144.png"><link rel="apple-touch-icon" sizes="152x152" href="/wp-content/themes/shunno/inc/assets/logos/apple-touch-icon-152x152.png"><link rel="apple-touch-icon" sizes="180x180" href="/wp-content/themes/shunno/inc/assets/logos/apple-touch-icon-180x180.png"><link rel="icon" type="image/png" href="/wp-content/themes/shunno/inc/assets/logos/android-chrome-192x192.png" sizes="192x192"><link rel="shortcut icon" href="/wp-content/themes/shunno/inc/assets/logos/favicon.ico?v=6"><meta name="application-name" content="MSPoweruser" /><meta name="msapplication-TileColor" content="#0592ff" /><meta name="msapplication-tooltip" content="MSPoweruser" /><meta name="msapplication-square70x70logo" content="/wp-content/themes/shunno/inc/assets/logos/wptiles/tiny.png" /><meta name="msapplication-square150x150logo" content="/wp-content/themes/shunno/inc/assets/logos/wptiles/square.png" /><meta name="msapplication-wide310x150logo" content="/wp-content/themes/shunno/inc/assets/logos/wptiles/wide.png" /><meta name="msapplication-square310x310logo" content="/wp-content/themes/shunno/inc/assets/logos/wptiles/large.png" /> <script charset="UTF-8" src="//cdn.sendpulse.com/9dae6d62c816560a842268bde2cd317d/js/push/6fd087f730cb740325c38e8d1e41066e_1.js" async></script> <meta name="msapplication-notification" content="frequency=1800;polling-uri=https://mspoweruser.com/notifications?id=0;polling-uri2=https://mspoweruser.com/notifications?id=1;polling-uri3=https://mspoweruser.com/notifications?id=2;polling-uri4=https://mspoweruser.com/notifications?id=3;polling-uri5=https://mspoweruser.com/notifications?id=4; cycle=1" /></head><body class="post-template-default single single-post postid-390749 single-format-standard"><div id="shunnoham-page" class="hfeed site"><header role="banner"><nav class="shunno-header shunno-mm navbar navbar-fixed-top navbar-default" role="navigation"><div class="shunno-container container"><div class="shunno-logo navbar-header"> <a href="https://mspoweruser.com" title="MSPoweruser - Microsoft and Technology News"><svg version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" xmlns:a="http://ns.adobe.com/AdobeSVGViewerExtensions/3.0/" x="0px" y="0px" class="mspu-logo" viewBox="0 0 108.8 129.3" enable-background="new 0 0 108.8 129.3" xml:space="preserve"> <defs> </defs> <path fill="#FFFFFF" d="M50.8,57.6l-7.2,51.2H0V57.6H50.8z M58.9,0H0v51.2h51.6L58.9,0z M47,129.3l20.5-20.5h41.3V57.6H57.2 L47,129.3z M65.2,0L58,51.2h50.8V0H65.2z" /> </svg><span class="name">MSPU</span></a><div class="shunno-nav-menu-button" data-toggle="collapse" data-target="#shunno-ham-mobile" aria-expanded="false"><div class="hamburger-menu"></div></div></div><div id="shunno-ham-mobile" class="shunno-mobile-ham collapse"><ul class="nav shunno-main-nav navbar-nav"><li><a href="https://mspoweruser.com/gaming">Gaming</a></li><li><a href="https://mspoweruser.com/windows-11">Windows 11</a></li><li><a href="https://mspoweruser.com/windows-10">Windows 10</a></li><li><a href="https://mspoweruser.com/smartphones">Smartphones</a></li><li><a href="https://mspoweruser.com/surface">Surface</a></li><li><a href="https://mspoweruser.com/Enterprise">Enterprise</a></li><li><a href="https://mspoweruser.com/tips">Tip us</a></li><li><a href="https://mspoweruser.com/settings">Settings</a></li><form role="search" autocomplete="off" method="get" id="search-mobile" action="https://mspoweruser.com/"><div> <label for="name">Text Input:</label> <input type="text" name="s" id="s" value="" tabindex="1" placeholder="Search something....will you?" /> <input type="submit" value="Submit" /></div></form></ul></div><div id="shunno-ham" class="collapse navbar-default shunnocanvas navbar-collapse"><ul class="nav shunno-main-nav navbar-nav"><li class="dropdown shunno-drop"> <a id="megamenu-items-loader-gaming" title="Read the latest articles related to Windows 10 and Xbox games" class="mspu-item dropdown-toggle disabled" href="https://mspoweruser.com/gaming" data-toggle="dropdown">Gaming</a></li><li class="dropdown shunno-drop shunno-mm-fw"> <a id="megamenu-items-loader-windows11" title="Read the latest articles related to Windows 11" class="mspu-item dropdown-toggle disabled" href="https://mspoweruser.com/windows-11" data-toggle="dropdown">Windows 11 <span class="caret"></span></a><ul class="dropdown-menu shunno-mm"><li><div class="loader loader-windows11"></div><div id="shunno-megamenu-windows11"></div></li></ul></li><li class="dropdown shunno-drop shunno-mm-fw"> <a id="megamenu-items-loader-windows" title="Read the latest articles related to Windows 10" class="mspu-item dropdown-toggle disabled" href="https://mspoweruser.com/windows-10" data-toggle="dropdown">Windows 10 <span class="caret"></span></a><ul class="dropdown-menu shunno-mm"><li><div class="loader loader-windows"></div><div id="shunno-megamenu-windows"></div></li></ul></li><li class="dropdown shunno-drop shunno-mm-fw"> <a id="megamenu-items-loader-wp" title="Read the latest articles related to Android, iPhones, and Windows Phones" class="mspu-item dropdown-toggle disabled" href="https://mspoweruser.com/smartphones" data-toggle="dropdown">Smartphones <span class="caret"></span></a><ul class="dropdown-menu shunno-mm"><li><div class="loader loader-wp"></div><div id="shunno-megamenu-wp"></div></li></ul></li><li class="shunno-tablet-hide"> <a class="mspu-item" href="https://mspoweruser.com/reviews" title="Get all the latest in-depth game, hardware, and software reviews!">Reviews</a></li></ul><ul class="nav navbar-nav navbar-right shunno-sec-nav"><li class="shunno-fbr shunno-settings"><a href="/settings" title="Customize theme, change settings and more!">Settings</a></li><li class="shunno-fbr shunno-tipus"><a href="/tips" title="Got a news? Make sure to tip us!">Tip us</a></li><li class="shunno-fbr shunno-forum"><a href="http://discuss.mspoweruser.com" title="Join the discussion in the MSPU Forums!">Forum</a></li></ul><ul class="nav navbar-nav navbar-rzr-search"><li class="shunno-search"><form role="search" autocomplete="off" method="get" id="search" action="https://mspoweruser.com/"><div> <label for="name">Text Input:</label> <input type="text" name="s" id="s" value="" tabindex="1" placeholder="Search something....will you?" /> <input type="submit" value="Submit" /></div></form></li></ul></div></div></nav></header><div class="shunnopagenavoverlay"></div><header class="shunno-full-header" style="background-image: url('https://mspoweruser.com/wp-content/uploads/2019/04/Google-Play-Store.jpg');"><div class="shunno-full-meta-box"><div class="shunno-meta-full"><h1 class="entry-title">Google cuts Google Play fees to 15% or less for most developers</h1><div class="entry-meta"><div class="shunno-post-rate-meta"><div class="shunnopostmetainfo"><p class="pppp">by <a title="View the author's profile" href="https://mspoweruser.com/author/surur/">Surur</a></p> &nbsp;<p><a class="twitter-link-single" target="_blank" title="View the author's Twitter profile" href="https://twitter.com/intent/user?screen_name=mspoweruser"><i class="shunno shunno-twitter"></i>@mspoweruser</a></p><div class='shunno-post-time'><i class="shunno shunno-clock"></i><time class='timeago'>Oct 22, 2021 at 15:25 GMT</time><time class='timeagohover'>39 seconds ago</time></div></div></div></div></div></div></header><div id="primary" class="content-area container"><main id="main" class="site-main shunno-single-article" role="main"><div class="shunno-single-article-internal entry-full-width"><div id="post-390749" class="shunno-article"><div class="shunno-single-main"><div class="shunno-728-header-ad"><script type="text/javascript">var width=window.innerWidth||document.documentElement.clientWidth||document.body.clientWidth;google_ad_client="ca-pub-6210711459792056",width>800?(google_ad_slot="7166200401",google_ad_width=728,google_ad_height=90):800>=width&&width>400?(google_ad_slot="8651626403",google_ad_width=300,google_ad_height=250):(google_ad_slot="8651626403",google_ad_width=300,google_ad_height=250);</script><script type="text/javascript" src="https://pagead2.googlesyndication.com/pagead/show_ads.js"></script></div><div class="entry-content col-md-8 shunno-fw-alternate"><article class="singa"><p><a href="https://android-developers.googleblog.com/2021/10/evolving-business-model.html" target="_blank" rel="noopener">Google has announced</a> that it is making significant cuts to the service fees it charge to Google Play developers.</p><p>The company noted that 97% of developers had free apps and monetized outside the Play Store, and were not subject to fees in any case.</p><p>For the 3% of developers who transacted via the Store, Google was cutting most fees to 15% or less.</p><ul><li>For app purchases and in-app purchases, the service fee is 15% for the first $1 million of earnings each year when enrolled and 30% subsequently, which gives smaller developers more help as they scale their business.</li><li>The fee for all subscriptions revenue is 15%, reflecting developer investment in keeping subscribers for the long run. Previously it was 30% for the first year and 15% for the next year onwards, but this did not help companies who had lots of churn.</li><li>Developers in certain programs, like the Play Media Experience Program, may be eligible for a reduced fee based on high content costs.</li><li>In addition to the apps on the Play Store, Google has also announced fee reductions for e-books and music streaming services on the platform, taking its cut down to 10% under certain eligibility conditions.</li></ul><p>Google says this means 99% of developers will only pay 15% or less, after the changes come into effect on the 1st January 2022.</p><p>Google says they made the changes as part of its effort to listen to developers, but we can not of course ignore the increasing anti-trust pressure on app stores such as Google Play Store and the iOS App Store, which appears to have resulted in significant shifts in policy from both parties.</p><p>via <a href="https://www.bleepingcomputer.com/news/google/google-cuts-play-store-dev-fees-to-15-percent-for-all-subscriptions/" target="_blank" rel="noopener">BleepingComputer</a></p></article><footer class="entry-footer"><div class="shunno-728-header-ad"><script type="text/javascript">var width=window.innerWidth||document.documentElement.clientWidth||document.body.clientWidth;google_ad_client="ca-pub-6210711459792056",width>800?(google_ad_slot="7166200401",google_ad_width=728,google_ad_height=90):800>=width&&width>400?(google_ad_slot="8651626403",google_ad_width=300,google_ad_height=250):(google_ad_slot="8651626403",google_ad_width=300,google_ad_height=250);</script><script type="text/javascript" src="https://pagead2.googlesyndication.com/pagead/show_ads.js"></script></div> <span class="shunno-lables"> <span>Related</span><ul class="post-meta-spans"> <a href="https://mspoweruser.com/tag/google-play/"><li>google play</li></a></ul> </span><div class="shunno-share-block"><ul><li> <a class="shunno-share-twitter" title="Tweet on Twitter" href="https://twitter.com/intent/tweet?text=Google cuts Google Play fees to 15% or less for most developers - https://mspoweruser.com/google-cuts-google-play-fees-to-15-or-less-for-most-developers/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"> <i class="shunno shunno-twitter"></i> <span>Tweet</span> </a></li><li> <a class="shunno-share-facebook" title="Share on Facebook" href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fmspoweruser.com%2Fgoogle-cuts-google-play-fees-to-15-or-less-for-most-developers%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"> <i class="shunno shunno-facebook"></i> <span>Share</span> </a></li><li> <a class="shunno-share-skype" title="Share on Skype" href="https://web.skype.com/share?url=https%3A%2F%2Fmspoweruser.com%2Fgoogle-cuts-google-play-fees-to-15-or-less-for-most-developers%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=417,height=655,toolbar=0'); return false;"> <i class="shunno shunno-skype"></i> </a></li><li> <a class="shunno-share-gplus" title="Share on Google+" href="http://plus.google.com/share?url=https%3A%2F%2Fmspoweruser.com%2Fgoogle-cuts-google-play-fees-to-15-or-less-for-most-developers%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"> <i class="shunno shunno-google"></i> </a></li><li> <a class="shunno-share-pocket" title="Save to read later on Pocket" href="https://getpocket.com/save?url=https%3A%2F%2Fmspoweruser.com%2Fgoogle-cuts-google-play-fees-to-15-or-less-for-most-developers%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"> <i class="shunno shunno-pocket"></i> </a></li><li> <a class="shunno-share-reddit" title="Submit to Reddit" href="http://reddit.com/submit?url=https%3A%2F%2Fmspoweruser.com%2Fgoogle-cuts-google-play-fees-to-15-or-less-for-most-developers%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=950,height=450,toolbar=0'); return false;"> <i class="shunno shunno-reddit"></i> </a></li></ul></div><div class="shunno-recommended-articles-full"><div class="shunno-recommended-articles"><div class="source-related-article-header">Read these next<i class="shunno-recommended-article-control shunno shunno-cancel"></i></div><div class="shunno-featured-article-big"><article title="Microsoft Surface Duo 2 with triple camera setup and Snapdragon 888 processor now available for order" class="shunno-feat-article"> <a href="https://mspoweruser.com/microsoft-surface-duo-triple-camera-snapdragon-888/"> <img width="800" height="553" src="https://mspoweruser.com/wp-content/uploads/2021/09/Microsoft-Surface-Duo-2-800x553.jpg" class="attachment-shunno-feat-thumb size-shunno-feat-thumb wp-post-image" alt="Microsoft Surface Duo 2" loading="lazy" srcset="https://mspoweruser.com/wp-content/uploads/2021/09/Microsoft-Surface-Duo-2-800x553.jpg 800w, https://mspoweruser.com/wp-content/uploads/2021/09/Microsoft-Surface-Duo-2-300x206.jpg 300w, https://mspoweruser.com/wp-content/uploads/2021/09/Microsoft-Surface-Duo-2-150x103.jpg 150w" sizes="(max-width: 800px) 100vw, 800px" /><div class="shunno-featured-article-meta"> <span class="featured-tag">Trending</span><h2>Microsoft Surface Duo 2 with triple camera setup and Snapdragon 888 processor now available for order</h2> <span>by Pradeep <i class="shunno shunno-comment"></i></span><span class="disqus-comment-count" data-disqus-identifier="390639 https://mspoweruser.com/?p=390639">0</span></div><div class="overlay"></div> </a></article><article title="How to sideload any Android app APK on Windows 11" class="shunno-feat-article"> <a href="https://mspoweruser.com/how-to-sideload-any-android-app-apk-on-windows-11/"> <img width="800" height="553" src="https://mspoweruser.com/wp-content/uploads/2021/10/Sideload-Android-apps-on-Windows-11-800x553.jpg" class="attachment-shunno-feat-thumb size-shunno-feat-thumb wp-post-image" alt="Sideload Android apps on Windows 11" loading="lazy" /><div class="shunno-featured-article-meta"> <span class="featured-tag">Trending</span><h2>How to sideload any Android app APK on Windows 11</h2> <span>by Pradeep <i class="shunno shunno-comment"></i></span><span class="disqus-comment-count" data-disqus-identifier="390628 https://mspoweruser.com/?p=390628">0</span></div><div class="overlay"></div> </a></article></div></div></div></footer><div class="shunno-728-header-ad"><script type="text/javascript">var width=window.innerWidth||document.documentElement.clientWidth||document.body.clientWidth;google_ad_client="ca-pub-6210711459792056",width>800?(google_ad_slot="7166200401",google_ad_width=728,google_ad_height=90):800>=width&&width>400?(google_ad_slot="8651626403",google_ad_width=300,google_ad_height=250):(google_ad_slot="8651626403",google_ad_width=300,google_ad_height=250);</script><script type="text/javascript" src="https://pagead2.googlesyndication.com/pagead/show_ads.js"></script></div><div class="shunno-single-comments" id="shunno-comments"><div class="shunno-block-title">Comments<span><a href="http://mspoweruser.com/guidelines/" title="Community guidelines"><i class="shunno-guidelines-reveal shunno-attention shunno"></i></a></span></div><div id="disqus_thread"></div></div></div><div id="secondary" class="col-md-4 widget-area" role="complementary"><aside id="shunno_widget_sidebar_advert-3" class="widget shunno_widget_sidebar_advert"><div class="shunno-block-title">Advertisement<a target="_blank" title="Is this advertisment misbehaving or playing sound automatically? Make sure to report this to us and we will disable it asap!" href="https://mspoweruser.com/report-ads"><i class="shunno-report-ad shunno-attention shunno"></i></a></div><div class="shunno-sidebar-advert"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px" data-ad-client="ca-pub-6210711459792056" data-ad-slot="9303911608"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></aside><aside id="shunno_posts_sidebar-4" class="widget widget_shunno_posts_sidebar"><div class="shunno-sidebar-articles"><div class="shunno-block-title shunno-widget-aritlces-title">Windows 10</div><article class="shunno-sidebar-widget-block-big"> <a href="https://mspoweruser.com/powershell-7-2-0-rc1-now-available-for-testing/" title="PowerShell 7.2.0 RC1 now available for testing" class="shunno-widget-overlay"><div class="shunno-side-thumb"><img width="395" height="260" src="https://mspoweruser.com/wp-content/uploads/2020/03/Powershell-7-image-395x260.jpg" class="attachment-shunno-loop-article-thumb size-shunno-loop-article-thumb wp-post-image" alt="" loading="lazy" srcset="https://mspoweruser.com/wp-content/uploads/2020/03/Powershell-7-image-395x260.jpg 395w, https://mspoweruser.com/wp-content/uploads/2020/03/Powershell-7-image-120x80.jpg 120w, https://mspoweruser.com/wp-content/uploads/2020/03/Powershell-7-image-105x70.jpg 105w" sizes="(max-width: 395px) 100vw, 395px" /></div><h2>PowerShell 7.2.0 RC1 now available for testing</h2> </a><p>by&nbsp;Surur&nbsp;on&nbsp;October 22, 2021</p></article><article class="shunno-sidebar-widget-block-small"> <a href="https://mspoweruser.com/microsoft-windows-10-november-2021-update-isos/" title="Microsoft releases Windows 10 November 2021 Update ISO images"><div class="shunno-side-thumb"><img width="105" height="70" src="https://mspoweruser.com/wp-content/uploads/2020/07/windows-10-dev-105x70.jpg" class="attachment-shunno-siiiii size-shunno-siiiii wp-post-image" alt="Microsoft windows 10" loading="lazy" srcset="https://mspoweruser.com/wp-content/uploads/2020/07/windows-10-dev-105x70.jpg 105w, https://mspoweruser.com/wp-content/uploads/2020/07/windows-10-dev-300x200.jpg 300w, https://mspoweruser.com/wp-content/uploads/2020/07/windows-10-dev-150x100.jpg 150w, https://mspoweruser.com/wp-content/uploads/2020/07/windows-10-dev-395x260.jpg 395w, https://mspoweruser.com/wp-content/uploads/2020/07/windows-10-dev-120x80.jpg 120w, https://mspoweruser.com/wp-content/uploads/2020/07/windows-10-dev.jpg 1200w" sizes="(max-width: 105px) 100vw, 105px" /></div><h3>Microsoft releases Windows 10 November 2021 Update ISO images</h3></a><p class='shunnowidgetsmallauthor'>by&nbsp;Pradeep</p></article><article class="shunno-sidebar-widget-block-small"> <a href="https://mspoweruser.com/surface-studio-2-surface-pro-7-october-update/" title="Surface Studio 2 and Surface Pro 7 getting October 2021 update"><div class="shunno-side-thumb"><img width="105" height="70" src="https://mspoweruser.com/wp-content/uploads/2018/10/surface-studio-2-8_web-105x70.jpg" class="attachment-shunno-siiiii size-shunno-siiiii wp-post-image" alt="" loading="lazy" srcset="https://mspoweruser.com/wp-content/uploads/2018/10/surface-studio-2-8_web-105x70.jpg 105w, https://mspoweruser.com/wp-content/uploads/2018/10/surface-studio-2-8_web-395x260.jpg 395w, https://mspoweruser.com/wp-content/uploads/2018/10/surface-studio-2-8_web-120x80.jpg 120w" sizes="(max-width: 105px) 100vw, 105px" /></div><h3>Surface Studio 2 and Surface Pro 7 getting October 2021 update</h3></a><p class='shunnowidgetsmallauthor'>by&nbsp;Rahul</p></article><article class="shunno-sidebar-widget-block-small"> <a href="https://mspoweruser.com/microsoft-release-cumulative-update-kb5006744-for-windows-10-1809/" title="Microsoft release Cumulative Update KB5006744 for Windows 10 1809 with Printing fix, more"><div class="shunno-side-thumb"><img width="105" height="70" src="https://mspoweruser.com/wp-content/uploads/2021/05/Microsoft-Windows-10-new-105x70.jpg" class="attachment-shunno-siiiii size-shunno-siiiii wp-post-image" alt="Microsoft Windows 10 new" loading="lazy" srcset="https://mspoweruser.com/wp-content/uploads/2021/05/Microsoft-Windows-10-new-105x70.jpg 105w, https://mspoweruser.com/wp-content/uploads/2021/05/Microsoft-Windows-10-new-395x260.jpg 395w, https://mspoweruser.com/wp-content/uploads/2021/05/Microsoft-Windows-10-new-120x80.jpg 120w" sizes="(max-width: 105px) 100vw, 105px" /></div><h3>Microsoft release Cumulative Update KB5006744 for Windows 10 1809 with Printing ...</h3></a><p class='shunnowidgetsmallauthor'>by&nbsp;Surur</p></article><article class="shunno-sidebar-widget-block-small"> <a href="https://mspoweruser.com/microsoft-windows-10-build-19044-1319-2/" title="Microsoft releases Windows 10 Build 19044.1319 (21H2) with several bug fixes to Release Preview Insiders"><div class="shunno-side-thumb"><img width="105" height="70" src="https://mspoweruser.com/wp-content/uploads/2020/07/windows-10-dev-105x70.jpg" class="attachment-shunno-siiiii size-shunno-siiiii wp-post-image" alt="Microsoft windows 10" loading="lazy" srcset="https://mspoweruser.com/wp-content/uploads/2020/07/windows-10-dev-105x70.jpg 105w, https://mspoweruser.com/wp-content/uploads/2020/07/windows-10-dev-300x200.jpg 300w, https://mspoweruser.com/wp-content/uploads/2020/07/windows-10-dev-150x100.jpg 150w, https://mspoweruser.com/wp-content/uploads/2020/07/windows-10-dev-395x260.jpg 395w, https://mspoweruser.com/wp-content/uploads/2020/07/windows-10-dev-120x80.jpg 120w, https://mspoweruser.com/wp-content/uploads/2020/07/windows-10-dev.jpg 1200w" sizes="(max-width: 105px) 100vw, 105px" /></div><h3>Microsoft releases Windows 10 Build 19044.1319 (21H2) with several bug fixes to ...</h3></a><p class='shunnowidgetsmallauthor'>by&nbsp;Pradeep</p></article></div></aside><aside id="shunno_widget_sidebar_sovrnadsmall-2" class="widget shunno_widget_sidebar_sovrnadsmall"><div class="shunno-block-title">Advertisement<a target="_blank" title="Is this advertisment misbehaving or playing sound automatically? Make sure to report this to us and we will disable it asap!" href="https://mspoweruser.com/report-ads"><i class="shunno-report-ad shunno-attention shunno"></i></a></div><div class="shunno-sidebar-advert"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6210711459792056" data-ad-slot="8185229604"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></aside><aside id="shunno_posts_sidebar_deals-2" class="widget widget_shunno_posts_sidebar_deals"><div class="shunno-sidebar-articles shunno-widget-deals"><div class="shunno-block-title shunno-widget-aritlces-title">Deals</div><article class="shunno-sidebar-widget-block-big"> <a href="https://mspoweruser.com/deal-alert-oneplus-9-pro-is-at-a-record-low-price/" title="Deal Alert: OnePlus 9 Pro is at a record low price" class="shunno-widget-overlay"><div class="shunno-side-thumb"><img width="395" height="260" src="https://mspoweruser.com/wp-content/uploads/2021/06/OnePlus-9-Pro-Hero-395x260.png" class="attachment-shunno-loop-article-thumb size-shunno-loop-article-thumb wp-post-image" alt="" loading="lazy" srcset="https://mspoweruser.com/wp-content/uploads/2021/06/OnePlus-9-Pro-Hero-395x260.png 395w, https://mspoweruser.com/wp-content/uploads/2021/06/OnePlus-9-Pro-Hero-120x80.png 120w, https://mspoweruser.com/wp-content/uploads/2021/06/OnePlus-9-Pro-Hero-105x70.png 105w" sizes="(max-width: 395px) 100vw, 395px" /></div><h2>Deal Alert: OnePlus 9 Pro is at a record low price</h2> </a><p class="article-excerpt">OnePlus 9 Pro is arguably this year&#8217;s one of the best flagship Android smartphones, and for a limited period of time, you buy the smartphone at a discounted price. The OnePlus 9 Pro 5G...</p></article><article class="shunno-sidebar-widget-block-small"> <a href="https://mspoweruser.com/microsoft-xbox-wireless-headset-deal-alert/" title="Deal Alert: Microsoft Xbox Wireless Headset now available for $88"><div class="shunno-side-thumb"><img width="105" height="70" src="https://mspoweruser.com/wp-content/uploads/2021/02/FE49A56E-B350-4532-B0FC-3702BE20367F-105x70.jpeg" class="attachment-shunno-siiiii size-shunno-siiiii wp-post-image" alt="Xbox Wireless Headset" loading="lazy" srcset="https://mspoweruser.com/wp-content/uploads/2021/02/FE49A56E-B350-4532-B0FC-3702BE20367F-105x70.jpeg 105w, https://mspoweruser.com/wp-content/uploads/2021/02/FE49A56E-B350-4532-B0FC-3702BE20367F-395x260.jpeg 395w, https://mspoweruser.com/wp-content/uploads/2021/02/FE49A56E-B350-4532-B0FC-3702BE20367F-120x80.jpeg 120w" sizes="(max-width: 105px) 100vw, 105px" /></div><h3>Deal Alert: Microsoft Xbox Wireless Headset now available for $88</h3></a><p class="article-excerpt">Microsoft Xbox Wireless Headset is now available for just $88 from Amazon US. The headset supports low latency, lossless audio for chat and consumption with the ability to use Windows Sonic,...</p></article><article class="shunno-sidebar-widget-block-small"> <a href="https://mspoweruser.com/surface-pro-7-is-331-cheaper-today/" title="Deal Alert: Surface Pro 7(256GB) Type Cover Bundle $331 cheaper today"><div class="shunno-side-thumb"><img width="105" height="70" src="https://mspoweruser.com/wp-content/uploads/2019/10/Surface-Pro-7-3-105x70.jpg" class="attachment-shunno-siiiii size-shunno-siiiii wp-post-image" alt="surface pro 7" loading="lazy" srcset="https://mspoweruser.com/wp-content/uploads/2019/10/Surface-Pro-7-3-105x70.jpg 105w, https://mspoweruser.com/wp-content/uploads/2019/10/Surface-Pro-7-3-395x260.jpg 395w, https://mspoweruser.com/wp-content/uploads/2019/10/Surface-Pro-7-3-120x80.jpg 120w" sizes="(max-width: 105px) 100vw, 105px" /></div><h3>Deal Alert: Surface Pro 7(256GB) Type Cover Bundle $331 cheaper today</h3></a><p class="article-excerpt">Microsoft Surface Pro 7(i5, 8GB/256GB) Type Cover Bundle is $331 cheaper today at Amazon. The Surface Pro 7 Type Cover Bundle can now be bought at $999, down from its original price point of...</p></article><article class="shunno-sidebar-widget-block-small"> <a href="https://mspoweruser.com/logitech-mx-master-2s-wireless-mouse-now-at-56/" title="Deal Alert: Logitech MX Master 2S Wireless Mouse now available at $56"><div class="shunno-side-thumb"><img width="105" height="70" src="https://mspoweruser.com/wp-content/uploads/2021/04/Logitech-MX-Master-2S-105x70.jpg" class="attachment-shunno-siiiii size-shunno-siiiii wp-post-image" alt="" loading="lazy" srcset="https://mspoweruser.com/wp-content/uploads/2021/04/Logitech-MX-Master-2S-105x70.jpg 105w, https://mspoweruser.com/wp-content/uploads/2021/04/Logitech-MX-Master-2S-395x260.jpg 395w, https://mspoweruser.com/wp-content/uploads/2021/04/Logitech-MX-Master-2S-120x80.jpg 120w" sizes="(max-width: 105px) 100vw, 105px" /></div><h3>Deal Alert: Logitech MX Master 2S Wireless Mouse now available at $56</h3></a><p class="article-excerpt">Logitech MX Master 2S Wireless Mouse is now selling at a discounted price at Amazon. You can now buy the wireless mouse at a price point of $55.99, down from $99.99. So if you do the math, i...</p></article><article class="shunno-sidebar-widget-block-small"> <a href="https://mspoweruser.com/save-70-razer-blackwidow-elite-mechanical-keyboard/" title="Deal Alert: Awesome discounts on Razer BlackWidow Elite Mechanical Gaming Keyboard"><div class="shunno-side-thumb"><img width="105" height="70" src="https://mspoweruser.com/wp-content/uploads/2021/10/Razer-BlackWidow-Elite-Mechanical-Gaming-Keyboard-105x70.jpg" class="attachment-shunno-siiiii size-shunno-siiiii wp-post-image" alt="" loading="lazy" srcset="https://mspoweruser.com/wp-content/uploads/2021/10/Razer-BlackWidow-Elite-Mechanical-Gaming-Keyboard-105x70.jpg 105w, https://mspoweruser.com/wp-content/uploads/2021/10/Razer-BlackWidow-Elite-Mechanical-Gaming-Keyboard-395x260.jpg 395w, https://mspoweruser.com/wp-content/uploads/2021/10/Razer-BlackWidow-Elite-Mechanical-Gaming-Keyboard-120x80.jpg 120w" sizes="(max-width: 105px) 100vw, 105px" /></div><h3>Deal Alert: Awesome discounts on Razer BlackWidow Elite Mechanical Gaming Keyboa...</h3></a><p class="article-excerpt">Awesome discounts on the Razer BlackWidow Elite Mechanical Gaming Keyboard are back! Amazon is once again offering a handsome discount of $70 on the purchase of the keyboard. You can now buy...</p></article><article class="shunno-sidebar-widget-block-small"> <a href="https://mspoweruser.com/samsung-galaxy-s20-discounted/" title="Deal Alert: Samsung Galaxy S20 5G(renewed) discounted at Amazon, again!"><div class="shunno-side-thumb"><img width="105" height="70" src="https://mspoweruser.com/wp-content/uploads/2020/01/Samsung-Galaxy-S20-series-9-105x70.jpg" class="attachment-shunno-siiiii size-shunno-siiiii wp-post-image" alt="" loading="lazy" srcset="https://mspoweruser.com/wp-content/uploads/2020/01/Samsung-Galaxy-S20-series-9-105x70.jpg 105w, https://mspoweruser.com/wp-content/uploads/2020/01/Samsung-Galaxy-S20-series-9-395x260.jpg 395w, https://mspoweruser.com/wp-content/uploads/2020/01/Samsung-Galaxy-S20-series-9-120x80.jpg 120w" sizes="(max-width: 105px) 100vw, 105px" /></div><h3>Deal Alert: Samsung Galaxy S20 5G(renewed) discounted at Amazon, again!</h3></a><p class="article-excerpt">Samsung Galaxy S20(renewed) smartphone is once again selling at a discounted price. Although more than a year old, the smartphone is nearly as powerful as the current flagship smartphones. S...</p></article><article class="shunno-sidebar-widget-block-small"> <a href="https://mspoweruser.com/deal-alert-acer-swift-x-with-ryzen-7-5800u-cpu-899/" title="Deal Alert: Acer Swift X with Ryzen 7 5800U CPU, NVIDIA 3050Ti and 16GB RAM available for $899"><div class="shunno-side-thumb"><img width="105" height="70" src="https://mspoweruser.com/wp-content/uploads/2021/05/Acer-Swift-X-105x70.jpg" class="attachment-shunno-siiiii size-shunno-siiiii wp-post-image" alt="Acer Swift X" loading="lazy" srcset="https://mspoweruser.com/wp-content/uploads/2021/05/Acer-Swift-X-105x70.jpg 105w, https://mspoweruser.com/wp-content/uploads/2021/05/Acer-Swift-X-395x260.jpg 395w, https://mspoweruser.com/wp-content/uploads/2021/05/Acer-Swift-X-120x80.jpg 120w" sizes="(max-width: 105px) 100vw, 105px" /></div><h3>Deal Alert: Acer Swift X with Ryzen 7 5800U CPU, NVIDIA 3050Ti and 16GB RAM avai...</h3></a><p class="article-excerpt">Early this year, Acer revealed the new Swift X ultrathin-and-light laptop. You can now get Acer Swift X with Ryzen 7 5800U CPU, NVIDIA RTX 3050Ti GPU, 16GB RAM and 512GB SSD for just $899. W...</p></article><article class="shunno-sidebar-widget-block-small"> <a href="https://mspoweruser.com/logitech-mx-master-2s-wireless-mouse-now-at-57/" title="Deal Alert: Logitech MX Master 2S Wireless Mouse now at $57"><div class="shunno-side-thumb"><img width="105" height="70" src="https://mspoweruser.com/wp-content/uploads/2021/04/Logitech-MX-Master-2S-105x70.jpg" class="attachment-shunno-siiiii size-shunno-siiiii wp-post-image" alt="" loading="lazy" srcset="https://mspoweruser.com/wp-content/uploads/2021/04/Logitech-MX-Master-2S-105x70.jpg 105w, https://mspoweruser.com/wp-content/uploads/2021/04/Logitech-MX-Master-2S-395x260.jpg 395w, https://mspoweruser.com/wp-content/uploads/2021/04/Logitech-MX-Master-2S-120x80.jpg 120w" sizes="(max-width: 105px) 100vw, 105px" /></div><h3>Deal Alert: Logitech MX Master 2S Wireless Mouse now at $57</h3></a><p class="article-excerpt">Logitech MX Master 2S Wireless Mouse is now available at a discounted price. You can now buy the wireless mouse at a price point of $54.99, down from $99.99. So if you do the math, it&#8217;...</p></article><article class="shunno-sidebar-widget-block-small"> <a href="https://mspoweruser.com/discount-on-microsoft-surface-pro-x/" title="Deal Alert: Save $539 on Microsoft Surface Pro X(renewed)"><div class="shunno-side-thumb"><img width="105" height="70" src="https://mspoweruser.com/wp-content/uploads/2019/10/Surface-Pro-X-105x70.jpg" class="attachment-shunno-siiiii size-shunno-siiiii wp-post-image" alt="Microsoft surface pro x" loading="lazy" srcset="https://mspoweruser.com/wp-content/uploads/2019/10/Surface-Pro-X-105x70.jpg 105w, https://mspoweruser.com/wp-content/uploads/2019/10/Surface-Pro-X-395x260.jpg 395w, https://mspoweruser.com/wp-content/uploads/2019/10/Surface-Pro-X-120x80.jpg 120w" sizes="(max-width: 105px) 100vw, 105px" /></div><h3>Deal Alert: Save $539 on Microsoft Surface Pro X(renewed)</h3></a><p class="article-excerpt">Microsoft Surface Pro X is arguably the best-looking 2-in-1 device you can buy right now. Surface Pro X is powered by an ARM-based custom SQ1 chipset that delivers great battery life with 4G...</p></article><article class="shunno-sidebar-widget-block-small"> <a href="https://mspoweruser.com/logitech-k800-wireless-keyboard-now-at-60/" title="Deal Alert: Awesome discount on Logitech K800 Wireless Illuminated Keyboard is back!"><div class="shunno-side-thumb"><img width="105" height="70" src="https://mspoweruser.com/wp-content/uploads/2021/09/Logitech-K800-Wireless-Illuminated-Keyboard-105x70.jpg" class="attachment-shunno-siiiii size-shunno-siiiii wp-post-image" alt="" loading="lazy" srcset="https://mspoweruser.com/wp-content/uploads/2021/09/Logitech-K800-Wireless-Illuminated-Keyboard-105x70.jpg 105w, https://mspoweruser.com/wp-content/uploads/2021/09/Logitech-K800-Wireless-Illuminated-Keyboard-300x196.jpg 300w, https://mspoweruser.com/wp-content/uploads/2021/09/Logitech-K800-Wireless-Illuminated-Keyboard-1200x783.jpg 1200w, https://mspoweruser.com/wp-content/uploads/2021/09/Logitech-K800-Wireless-Illuminated-Keyboard-150x98.jpg 150w, https://mspoweruser.com/wp-content/uploads/2021/09/Logitech-K800-Wireless-Illuminated-Keyboard-395x260.jpg 395w, https://mspoweruser.com/wp-content/uploads/2021/09/Logitech-K800-Wireless-Illuminated-Keyboard-120x80.jpg 120w, https://mspoweruser.com/wp-content/uploads/2021/09/Logitech-K800-Wireless-Illuminated-Keyboard.jpg 1404w" sizes="(max-width: 105px) 100vw, 105px" /></div><h3>Deal Alert: Awesome discount on Logitech K800 Wireless Illuminated Keyboard is b...</h3></a><p class="article-excerpt">Logitech K800 wireless keyboard is now selling at a discounted price at Amazon. You can now get buy it at a price point of $60, down from its original price point of $100 — that&#8217;s a ...</p></article></div></aside><aside id="shunno_widget_sidebar_sovrnad-2" class="widget shunno_widget_sidebar_sovrnad"><div class="shunno-block-title">Advertisement<a target="_blank" title="Is this advertisment misbehaving or playing sound automatically? Make sure to report this to us and we will disable it asap!" href="https://mspoweruser.com/report-ads"><i class="shunno-report-ad shunno-attention shunno"></i></a></div><div class="shunno-sidebar-advert"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px" data-ad-client="ca-pub-6210711459792056" data-ad-slot="6708496403"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></aside><aside id="custom_html-3" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><a href="https://opencritic.com/outlet/704/mspoweruser" target="_blank" rel="noopener"><img src="https://mspoweruser.com/wp-content/uploads/2019/05/opencriticlogo2.png" alt="Open Critic" /></a></div></aside></div></div></div></div></main></div></div></div><footer id="colophon" class="site-footer" role="contentinfo"><div class="shunno-footer-main container"><div class="col-md-4 footer-logo"> <a href="http://mspoweruser.com" title="MSPoweruser - All of Microsoft, all of the time!"> <img alt="shunno-footer-logo" src="//mspoweruser.com/wp-content/themes/shunno/inc/assets/footer-logos.png" style="width: 100%;"> </a></div><div class="col-md-8 footer-links"><ul class="site-links"> <a href="http://discuss.mspoweruser.com" target="_blank"><li>Forums</li></a> <a href="http://mspoweruser.com/about"><li>About Us</li></a> <a href="http://mspoweruser.com/contact"><li>Contact Us</li></a> <a href="http://mspoweruser.com/tips"><li>Tip Us</li></a> <a href="http://mspoweruser.com/submit-articles/"><li>Submit Articles</li></a> <a href="http://mspoweruser.com/guidelines"><li>Community Guidelines</li></a> <a href="http://mspoweruser.com/privacy"><li class="site-links-privacy">Privacy Policy</li></a></ul><ul class="social-links"> <a title="Follow the latest conversations on Disqus" href="https://disqus.com/home/forum/mspoweruser/"><li class="social-links-disqus"><i class="shunno shunno-disqus"></i></li></a> <a title="Subscribe to our RSS feed" href="https://mspoweruser.com/feed"><li><i class="shunno shunno-rss"></i></li></a> <a title="Follow us on Google+" href="https://plus.google.com/+mspoweruserhd"><li class="shunnogooglelink"><i class="shunno shunno-google"></i></li></a> <a title="Like us on Facebook" href="https://facebook.com/microsoftpoweruser"><li><i class="shunno shunno-facebook"></i></li></a> <a title="Follow us on Twitter" href="https://twitter.com/mspoweruser"><li><i class="shunno shunno-twitter"></i></li></a></ul></div><div class="footer-copyright"> <span>&copy; 2021 MSPoweruser - All rights reserved</span><span class="footer-queries">Not associated with Microsoft</span></div></div><div class="afs_ads">&nbsp;</div></footer><div style="display: none;" id="nxsFavNotice"><div id="nxsFavNoticeCnt">Posting....</div></div> <script type='text/javascript' id='contact-form-7-js-extra'>var wpcf7 = {"api":{"root":"https:\/\/mspoweruser.com\/wp-json\/","namespace":"contact-form-7\/v1"}};</script> <script type='text/javascript' id='disqus_count-js-extra'>var countVars = {"disqusShortname":"mspoweruser"};</script> <script type='text/javascript' id='disqus_embed-js-extra'>var embedVars = {"disqusConfig":{"platform":"wordpress"},"disqusIdentifier":"390749 https:\/\/mspoweruser.com\/?p=390749","disqusShortname":"mspoweruser","disqusTitle":"Google cuts Google Play fees to 15% or less for most developers","disqusUrl":"https:\/\/mspoweruser.com\/google-cuts-google-play-fees-to-15-or-less-for-most-developers\/","postId":"390749"};</script> <script src='https://stats.wp.com/e-202142.js' defer></script> <script>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.2.1',blog:'107264148',post:'390749',tz:'1',srv:'mspoweruser.com'} ]);
	_stq.push([ 'clickTrackerInit', '107264148', '390749' ]);</script> <a href="#0" class="shunno-top">Top</a></div> <script defer src="https://mspoweruser.com/wp-content/cache/autoptimize/js/autoptimize_92db44d24051164c7d1ee0e90ff35264.js"></script></body></html>